summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 11:35:31 +1000
committerPhillip Smith2015-06-02 11:35:31 +1000
commit7cfb35f659451ba9ed7a95ed255e0d4e687e4f27 (patch)
tree9d01b77d6f413c6fc7af8c9b1fc34ac4a00ebdd2
downloadaur-7cfb35f659451ba9ed7a95ed255e0d4e687e4f27.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89e41469823a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-iptables-rule
+ pkgdesc = Perl extension for holding iptables rule information in objects
+ pkgver = 0.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/IPTables-Rule/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PH/PHILLIPS/IPTables-Rule-0.01.tar.gz
+ md5sums = 5105e0d0bd1e360a9b1351f55f1aee85
+
+pkgname = perl-iptables-rule
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3e33f2266d6b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/IPTables-Rule-*.tar.gz
+/perl-iptables-rule-*.pkg.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96e6132f7ba0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+
+pkgname=perl-iptables-rule
+pkgver=0.01
+pkgrel=1
+pkgdesc="Perl extension for holding iptables rule information in objects"
+arch=('any')
+url="http://search.cpan.org/dist/IPTables-Rule/"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/P/PH/PHILLIPS/IPTables-Rule-$pkgver.tar.gz")
+md5sums=('5105e0d0bd1e360a9b1351f55f1aee85')
+
+build() {
+ cd "$srcdir"/IPTables-Rule-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/IPTables-Rule-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: