summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-12 10:47:16 +0300
committerAnton Leontiev2015-08-12 10:47:16 +0300
commitebcb3af2db5638b7a932c407f70b65ef37595af7 (patch)
treeae2a4bd8bf94da38cc6ea4d2ccd1f5cb25eb517d
parent8a46ea4f9ec0fb945fb00dc0c8db4012f2fb1177 (diff)
downloadaur-ebcb3af2db5638b7a932c407f70b65ef37595af7.tar.gz
Updated to v0.78
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--PKGBUILD.tt10
3 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fa3732dd336..fc0be3414f8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = perl-jifty-dbi
pkgdesc = An object-relational persistence framework for Jifty
- pkgver = 0.77
+ pkgver = 0.78
pkgrel = 1
- url = http://search.cpan.org/dist/Jifty-DBI
+ url = https://metacpan.org/release/Jifty-DBI
arch = any
license = GPL
license = PerlArtistic
@@ -34,8 +34,8 @@ pkgbase = perl-jifty-dbi
optdepends = perl-time-duration-parse>=0.06: duration filter
optdepends = perl-uri: URI filter
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/A/AL/ALEXMV/Jifty-DBI-0.77.tar.gz
- md5sums = 26c329a4c8fd85e33a2faf2c549ec64e
+ source = http://search.cpan.org/CPAN/authors/id/A/AL/ALEXMV/Jifty-DBI-0.78.tar.gz
+ md5sums = 512027a847753c08383597e4dffbf1af
pkgname = perl-jifty-dbi
diff --git a/PKGBUILD b/PKGBUILD
index 50006c95e1ab..ea2cc39cdd32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# CPAN Name : Jifty::DBI
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-jifty-dbi
-pkgver=0.77
+pkgver=0.78
pkgrel=1
pkgdesc='An object-relational persistence framework for Jifty'
arch=('any')
-url='http://search.cpan.org/dist/Jifty-DBI'
+url='https://metacpan.org/release/Jifty-DBI'
license=('GPL' 'PerlArtistic')
depends=(
@@ -42,22 +42,30 @@ optdepends=(
'perl-uri: URI filter')
options=(!emptydirs)
-source=(http://search.cpan.org/CPAN/authors/id/A/AL/ALEXMV/Jifty-DBI-0.77.tar.gz)
-md5sums=('26c329a4c8fd85e33a2faf2c549ec64e')
+source=(http://search.cpan.org/CPAN/authors/id/A/AL/ALEXMV/Jifty-DBI-0.78.tar.gz)
+md5sums=('512027a847753c08383597e4dffbf1af')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+}
build() {
- cd Jifty-DBI-0.77
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL --skipdeps INSTALLDIRS=vendor
+ cd Jifty-DBI-0.78
+ sanitize
+ perl Makefile.PL --skipdeps INSTALLDIRS=vendor
make
}
check() {
- cd Jifty-DBI-0.77
+ cd Jifty-DBI-0.78
+ sanitize
make test
}
package() {
- cd Jifty-DBI-0.77
+ cd Jifty-DBI-0.78
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index dab36bcc0c4d..1222c7ffba05 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -45,19 +45,27 @@ options=(!emptydirs)
source=([% source %])
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL --skipdeps INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL --skipdeps INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}