summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:13:08 -0600
committerJohn D Jones III2015-06-16 15:13:08 -0600
commitad383997f980769b8567b89777fc88940641d8c3 (patch)
tree9f664f13670d4d5acfb2887e8d9dd3589ab7c0ae
downloadaur-ad383997f980769b8567b89777fc88940641d8c3.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
3 files changed, 87 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..07ac426db3a6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-json-maybexs
+ pkgdesc = use Cpanel::JSON::XS with a fallback to JSON::XS and JSON::PP
+ pkgver = 1.002002
+ pkgrel = 1
+ url = http://search.cpan.org/dist/JSON-MaybeXS
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-without-module>=0.17
+ depends = perl-cpanel-json-xs>=2.3310
+ depends = perl>=5.006
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/JSON-MaybeXS-1.002002.tar.gz
+ md5sums = cb8c66ece7518270ea31ffc4951d5f02
+ sha512sums = a4421abe54ec2b71892f4a1e04794dd3cc99773659cb32e8bf95a89db411eaadc6d90145be0a25da70946edded021962f6eaa48e7d8287773eb5d677ee042e7f
+
+pkgname = perl-json-maybexs
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07ac426db3a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-json-maybexs
+ pkgdesc = use Cpanel::JSON::XS with a fallback to JSON::XS and JSON::PP
+ pkgver = 1.002002
+ pkgrel = 1
+ url = http://search.cpan.org/dist/JSON-MaybeXS
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-without-module>=0.17
+ depends = perl-cpanel-json-xs>=2.3310
+ depends = perl>=5.006
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/JSON-MaybeXS-1.002002.tar.gz
+ md5sums = cb8c66ece7518270ea31ffc4951d5f02
+ sha512sums = a4421abe54ec2b71892f4a1e04794dd3cc99773659cb32e8bf95a89db411eaadc6d90145be0a25da70946edded021962f6eaa48e7d8287773eb5d677ee042e7f
+
+pkgname = perl-json-maybexs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffe1ce01d08b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: Christos Nouskas <nous@archlinux.us>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-json-maybexs'
+pkgver='1.002002'
+pkgrel='1'
+pkgdesc="use Cpanel::JSON::XS with a fallback to JSON::XS and JSON::PP"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-cpanel-json-xs>=2.3310' 'perl>=5.006')
+makedepends=()
+checkdepends=('perl-test-without-module>=0.17')
+url='http://search.cpan.org/dist/JSON-MaybeXS'
+source=('http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/JSON-MaybeXS-1.002002.tar.gz')
+md5sums=('cb8c66ece7518270ea31ffc4951d5f02')
+sha512sums=('a4421abe54ec2b71892f4a1e04794dd3cc99773659cb32e8bf95a89db411eaadc6d90145be0a25da70946edded021962f6eaa48e7d8287773eb5d677ee042e7f')
+_distdir="JSON-MaybeXS-1.002002"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: