summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-05-01 18:44:20 +0200
committerhaawda2018-05-01 18:44:20 +0200
commite94a3666f78e8d3ec5ff8cddb5847c2c3e2723e2 (patch)
treebfaa5aa7621398962d56c5868665892789c331f5
downloadaur-e94a3666f78e8d3ec5ff8cddb5847c2c3e2723e2.tar.gz
initial upload
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD47
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d982d0088de6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = perl-latexml-git
+ pkgdesc = LaTeX to XML converter
+ pkgver = 0.8.2.445.g38fc034e
+ pkgrel = 1
+ url = http://dlmf.nist.gov/LaTeXML/
+ arch = any
+ license = custom
+ depends = perl
+ depends = perl-parse-recdescent
+ depends = perl-text-unidecode
+ depends = imagemagick6
+ depends = perl-xml-libxml
+ depends = perl-xml-libxslt
+ depends = db
+ depends = texlive-core
+ depends = perl-image-size
+ depends = perl-file-which
+ depends = perl-libwww
+ depends = perl-io-string
+ depends = perl-archive-zip
+ provides = perl-latexml
+ conflicts = perl-latexml
+ options = !emptydirs
+ source = git+https://github.com/brucemiller/LaTeXML.git
+ sha512sums = SKIP
+
+pkgname = perl-latexml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee8fe212a80c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=perl-latexml-git
+_realname=LaTeXML
+pkgver=0.8.2.445.g38fc034e
+pkgrel=1
+pkgdesc="LaTeX to XML converter"
+arch=('any')
+license=('custom')
+url="http://dlmf.nist.gov/LaTeXML/"
+depends=('perl' 'perl-parse-recdescent' 'perl-text-unidecode'
+ 'imagemagick6' 'perl-xml-libxml'
+ 'perl-xml-libxslt' 'db' 'texlive-core'
+ 'perl-image-size' 'perl-file-which'
+ 'perl-libwww' 'perl-io-string' 'perl-archive-zip')
+options=('!emptydirs')
+provides=('perl-latexml')
+conflicts=('perl-latexml')
+source=("git+https://github.com/brucemiller/LaTeXML.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${_realname}
+ printf "%s" $(git describe | cut -c2-| tr - .)
+}
+
+build() {
+ cd ${_realname}
+
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor INSTALLVENDORBIN=/usr/bin INSTALLVENDORSCRIPT=/usr/bin TEXMF=/usr/share/texmf
+ make
+}
+
+package() {
+ cd ${_realname}
+ make install DESTDIR="$pkgdir"
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -name .packlist -delete
+ # add liense file
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ # add manual
+ install -Dm644 manual.pdf "$pkgdir"/usr/share/$pkgname/doc/manual.pdf
+}