summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2017-09-27 13:59:59 +0200
committerint2017-09-27 13:59:59 +0200
commitb4bba599a742eda1238ad01a0117d2c71db494eb (patch)
treed3f264fe8cfe7bb95b882105e377fe938e58622a
downloadaur-b4bba599a742eda1238ad01a0117d2c71db494eb.tar.gz
Perl/CPAN Module Lingua::Stem::Snowball.
This is one of the perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -r -a" after downloading and unpacking the koha-tarball for a list of all required packages.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6375fc88ce2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-lingua-stem-snowball
+ pkgdesc = Perl/CPAN Module Lingua::Stem::Snowball: Perl interface to Snowball stemmers.
+ pkgver = 0.952
+ pkgrel = 1
+ url = https://metacpan.org/release/Lingua-Stem-Snowball
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl>=5.6.2
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CR/CREAMYG/Lingua-Stem-Snowball-0.952.tar.gz
+ md5sums = 6b0085c6fd8ec894e34c593078aa169a
+ sha512sums = 53e1f48094d60f2ca2fe4303119bb140ea166a619d5c0141925f62bbfaac0bb1d87053eb49bf5478144efea700ea9ecd7686b11bce94ab6f76fda7550b376c58
+
+pkgname = perl-lingua-stem-snowball
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b60ca3fae685
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer : int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-lingua-stem-snowball'
+pkgver='0.952'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module Lingua::Stem::Snowball: Perl interface to Snowball stemmers."
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.6.2')
+makedepends=()
+url='https://metacpan.org/release/Lingua-Stem-Snowball'
+source=('http://search.cpan.org/CPAN/authors/id/C/CR/CREAMYG/Lingua-Stem-Snowball-0.952.tar.gz')
+md5sums=('6b0085c6fd8ec894e34c593078aa169a')
+sha512sums=('53e1f48094d60f2ca2fe4303119bb140ea166a619d5c0141925f62bbfaac0bb1d87053eb49bf5478144efea700ea9ecd7686b11bce94ab6f76fda7550b376c58')
+_distdir="Lingua-Stem-Snowball-0.952"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: