summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 11:07:20 -0600
committerBrian Bidulock2015-06-10 11:07:20 -0600
commit69af0cd1367bcd14e2dd1a754aef2590374d06fa (patch)
tree118b89d1fdbcf3fcc57098b8191f72eaadae3615
downloadaur-69af0cd1367bcd14e2dd1a754aef2590374d06fa.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog71
-rw-r--r--PKGBUILD26
3 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efe3c1858cd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-linux-smaps
+ pkgdesc = Linux::Smaps - a Perl interface to /proc/PID/smaps
+ pkgver = 0.13
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Linux-Smaps/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ depends = perl-class-member
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/O/OP/OPI/Linux-Smaps-0.13.tar.gz
+ md5sums = 28bbe178b1b26935c454fa8ccdd16929
+
+pkgname = perl-linux-smaps
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..4c7945c377fb
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,71 @@
+Revision history for Perl extension Linux::Smaps.
+
+0.13 Sun 1 Dec 20:34:43 CET 2013
+ - some kernels allow the user to open /proc/*/smaps for reading even
+ if the process is not allowed to read the content. In the latter case
+ /proc/*/smaps then appears to be empty. Linux::Smaps turns that into
+ an EACCES.
+ - drop 05.t because it's obsolete
+
+0.12 Mon May 20 20:44:08 CEST 2013
+ - on some platforms /proc/1/smaps is readable for the ordinary user
+ t/04.t used to fail in this case.
+
+0.11 Wed May 8 20:11:09 CEST 2013
+ - adjust for kernel 3.8
+
+0.09 Fri Apr 1 16:14:24 CEST 2011
+ - fix the integer overflow test in t/03.t
+
+0.08 Wed Mar 30 09:59:55 CEST 2011
+ * performance tuning
+ - postpone VMA header parsing until really needed. Here is what I
+ get now in comparison for Linux::Smaps->new->all. "tiny" is
+ Linux::Smaps::Tiny::get_smaps_summary (Linux::Smaps::Tiny version 0.03)
+
+ v0.06: 21.1097 (20.61 usr + 0.47 sys = 21.08 CPU) @ 71.39/s (n=1505)
+ v0.07: 21.5743 (19.47 usr + 2.00 sys = 21.47 CPU) @ 319.05/s (n=6850)
+ v0.08: 20.2325 (17.81 usr + 2.32 sys = 20.13 CPU) @ 405.61/s (n=8165)
+ tiny: 21.6513 (18.16 usr + 3.25 sys = 21.41 CPU) @ 559.60/s (n=11981)
+
+ Rate v0.06 v0.07 v0.08 tiny
+ v0.06 71.4/s -- -78% -82% -87%
+ v0.07 319/s 347% -- -21% -43%
+ v0.08 406/s 468% 27% -- -28%
+ tiny 560/s 684% 75% 38% --
+
+ - clear_refs() interface
+
+0.07 Tue Mar 29 16:06:12 CEST 2011
+ * performance tuning
+ - drop Class::Member usage
+ - change internal object representation to arrays rather than hashes
+
+0.06 Wed Jun 4 11:39:18 CEST 2008
+ - sometimes vmas are listed twice in /proc/self/smaps.
+ (perhaps a kernel bug) Linux::Smaps ignores the duplicates
+ - using POSIX::setlocale during test to ensure english error messages
+
+0.05 Tue Oct 9 10:42:43 CEST 2007
+ - VMA accessor methods and Smaps summary methods are created on
+ the fly. So, new features added by the kernel won't break the
+ module easily.
+
+0.04 Mon Oct 8 16:06:07 CEST 2007
+ - small bugfix
+
+0.03 Mon Oct 8 15:34:43 CEST 2007
+ - better error propagation from the constructor
+ - use warnings FATAL
+ - exclude portable warning to make it work on 64bit boxes
+ - filename and procdir parameters to the constructor
+ - documentation update including a note on mlockall()
+ - is_deleted attribute
+
+0.02 Fri Sep 23 19:18:17 2005
+ - $self->diff function
+
+0.01 Fri Aug 5 11:55:44 2005
+ - original version; created by h2xs 1.23 with options
+ -n Linux::Smaps -X -b 5.8.0 -A -f
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2e467ad47bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+pkgname=perl-linux-smaps
+_pkgname=Linux-Smaps
+pkgver=0.13
+pkgrel=1
+pkgdesc='Linux::Smaps - a Perl interface to /proc/PID/smaps'
+arch=('i686' 'x86_64')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/${_pkgname}/"
+depends=('perl' 'perl-class-member')
+changelog="ChangeLog"
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/O/OP/OPI/${_pkgname}-$pkgver.tar.gz)
+md5sums=('28bbe178b1b26935c454fa8ccdd16929')
+
+build() {
+ cd $srcdir/${_pkgname}-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}-$pkgver
+ make install DESTDIR=$pkgdir
+}