summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2017-10-09 01:07:38 +0200
committerint2017-10-09 01:07:38 +0200
commit4574cea322a8f335d99f6f6136c8b2e4f2ddf9c9 (patch)
tree4fb13cdda61b77daaa82e767087aeec818162527
downloadaur-perl-locale-currency-format.tar.gz
Perl/CPAN Module Locale::Currency::Format
This is one of the perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -r -a" after downloading and unpacking the koha-tarball for a list of all required packages. This is with the cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d5cb69edfea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-locale-currency-format
+ pkgdesc = Perl/CPAN Module Locale::Currency::Format: Perl functions for formatting monetary values
+ pkgver = 1.35
+ pkgrel = 1
+ url = https://metacpan.org/release/Locale-Currency-Format
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/T/TN/TNGUYEN/Locale-Currency-Format-1.35.tar.gz
+ md5sums = 3eb24b6459a3a3f6201773c4cbac2b32
+ sha512sums = fce9a107e7efbff39f853ff7937a934300cc85ddd81a5bdb1e0c18dc49e6b21d1312652a5c939962c05f3402d25ba4ed69feaeb97588183685e755243666e8c6
+
+pkgname = perl-locale-currency-format
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51081fe4b747
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer : int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-locale-currency-format'
+pkgver='1.35'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module Locale::Currency::Format: Perl functions for formatting monetary values"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/Locale-Currency-Format'
+source=('http://search.cpan.org/CPAN/authors/id/T/TN/TNGUYEN/Locale-Currency-Format-1.35.tar.gz')
+md5sums=('3eb24b6459a3a3f6201773c4cbac2b32')
+sha512sums=('fce9a107e7efbff39f853ff7937a934300cc85ddd81a5bdb1e0c18dc49e6b21d1312652a5c939962c05f3402d25ba4ed69feaeb97588183685e755243666e8c6')
+_distdir="Locale-Currency-Format-1.35"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: