summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrrossum2015-07-29 16:25:36 -0500
committerdrrossum2015-07-29 16:25:36 -0500
commitc41ef5132c24e90ef7cbed8f3b5a5016c6e04867 (patch)
tree35d3516fd1b59c5081a286b5b28c9384e94d33fc
downloadaur-c41ef5132c24e90ef7cbed8f3b5a5016c6e04867.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63a2d18ac0d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-lwp-protocol-socks
+ pkgdesc = Adds support for the socks protocol and proxy facility
+ pkgver = 1.6
+ pkgrel = 1
+ url = http://search.cpan.org/~scr/LWP-Protocol-socks-1.3/
+ arch = any
+ license = GPL
+ depends = perl-libwww
+ depends = perl-io-socket-ssl
+ depends = perl-io-socket-socks
+ depends = perl-lwp-protocol-https
+ source = http://search.cpan.org/CPAN/authors/id/S/SC/SCR/LWP-Protocol-socks-1.6.tar.gz
+ md5sums = 251f88101bb59207171f126c190faac9
+
+pkgname = perl-lwp-protocol-socks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..573b370bf400
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: jsteel <mail at jsteel dot org>
+# Contributor: Petrenko Alexey <alexey-p at uralweb dot ru>
+
+pkgname=perl-lwp-protocol-socks
+pkgver=1.6
+pkgrel=1
+pkgdesc='Adds support for the socks protocol and proxy facility'
+url='http://search.cpan.org/~scr/LWP-Protocol-socks-1.3/'
+depends=('perl-libwww' 'perl-io-socket-ssl' 'perl-io-socket-socks' 'perl-lwp-protocol-https')
+arch=('any')
+license=('GPL')
+source=(http://search.cpan.org/CPAN/authors/id/S/SC/SCR/LWP-Protocol-socks-$pkgver.tar.gz)
+md5sums=('251f88101bb59207171f126c190faac9')
+
+build() {
+ cd "$srcdir/LWP-Protocol-socks-$pkgver"
+
+ perl Makefile.PL INSTALLDIRS=vendor
+
+ make
+}
+
+check() {
+ cd "$srcdir/LWP-Protocol-socks-$pkgver"
+
+ make test
+}
+
+package() {
+ cd "$srcdir/LWP-Protocol-socks-$pkgver"
+
+ make DESTDIR="$pkgdir"/ install
+
+ # Removing unnecessary stuff
+ find "$pkgdir" -type f -name 'perllocal.pod' -delete;
+ find "$pkgdir" -type f -name '.packlist' -delete;
+}