summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.A. López-Valencia2015-12-28 08:22:59 -0500
committerP.A. López-Valencia2015-12-28 08:22:59 -0500
commit61168686ae4c773ba635c4f1b280a680a6308ab0 (patch)
tree348d63df528b3d0ba72fb3851f0c3d587ed574b6
downloadaur-61168686ae4c773ba635c4f1b280a680a6308ab0.tar.gz
perl-math-bigint 1.999710-1 I finally got around to yrdy if I could install this on top of a system perl install without breaking it.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD38
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0153f3231736
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Dec 28 13:20:38 UTC 2015
+pkgbase = perl-math-bigint
+ pkgdesc = Big integer calculations using the GNU Multiple Precision Arithmetic Library.
+ pkgver = 1.999710
+ pkgrel = 1
+ url = http://search.cpan.org/~PJACKLAM/Math-BigInt-1.999710/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.20.0
+ depends = gmp
+ options = !emptydirs
+ source = http://cpan.perl.org/modules/by-authors/id/P/PJ/PJACKLAM/Math-BigInt-1.999710.tar.gz
+ sha256sums = 879514c3dda33b6f05816569ca1a0f31b650df87660ecf80afbd60e396118610
+
+pkgname = perl-math-bigint
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa9b07747604
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*~
+pkg/
+src/
+*.gz
+*.bz2
+*.xz
+*.lzo
+*.xz4
+*.tgz
+*.tbz
+*.txz
+*.tar
+*.jar
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c83de84d586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# See AUR interface to contact current maintainer.
+
+_author=PJACKLAM
+_perlmod=Math-BigInt
+pkgname=perl-math-bigint
+pkgver=1.999710
+pkgrel=1
+pkgdesc="Big integer calculations using the GNU Multiple Precision Arithmetic Library."
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.20.0' 'gmp')
+options=(!emptydirs)
+source=(http://cpan.perl.org/modules/by-authors/id/P/PJ/$_author/$_perlmod-$pkgver.tar.gz)
+sha256sums=('879514c3dda33b6f05816569ca1a0f31b650df87660ecf80afbd60e396118610')
+
+
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make install DESTDIR="$pkgdir/"
+
+ find ${pkgdir} -name '.packlist' -delete
+ find ${pkgdir} -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et ft=sh: