summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2017-09-13 20:11:50 +0300
committertrizen2017-09-13 20:11:50 +0300
commit6eda38666e7d7976d29b020b1cd2da182597c2a1 (patch)
tree6b43f73035d46acae1ba0b6b6fc765fb524ee797
parent01327242cd04f9f33d46f21c5b0751f98b12fc48 (diff)
downloadaur-6eda38666e7d7976d29b020b1cd2da182597c2a1.tar.gz
Switched to Metacpan.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD63
2 files changed, 47 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29dc170bc01b..7e7b79ecaff0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Sep 13 17:11:42 UTC 2017
pkgbase = perl-math-bigint-gmp
- pkgdesc = Big integer calculations using the GNU Multiple Precision Arithmetic Library.
+ pkgdesc = Math::BigInt::GMP - backend library for Math::BigInt etc. based on GMP
pkgver = 1.6004
pkgrel = 1
- url = http://search.cpan.org/~PJACKLAM/Math-BigInt-GMP-1.6004/
+ url = https://metacpan.org/release/Math-BigInt-GMP
arch = i686
arch = x86_64
- license = GPL
license = PerlArtistic
- depends = perl>=5.22.1
- depends = gmp
+ license = GPL
+ depends = gmp>=6.1.2
+ depends = perl>=5.6.1
depends = perl-math-bigint>=1.999808
options = !emptydirs
- source = http://cpan.perl.org/modules/by-authors/id/P/PJ/PJACKLAM/Math-BigInt-GMP-1.6004.tar.gz
- sha256sums = 236229dd7d323f142d8b24b83d21061152432096be7aea026002b8dbbba733f2
+ source = https://cpan.metacpan.org/authors/id/P/PJ/PJACKLAM/Math-BigInt-GMP-1.6004.tar.gz
+ md5sums = 08a859a57c7512b1c92e57d717893154
+ sha512sums = 54b416fe577512691a97b9a06f8ca2ffc4ab63e0d11325f5926c42a4248b87325c2b5db0c57b2239819e863891ea40ab028b0f061ed9c8bbbf6886c467cb8d1e
pkgname = perl-math-bigint-gmp
diff --git a/PKGBUILD b/PKGBUILD
index 9ab08a70eeaa..f42e7fab42a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,49 @@
-# See AUR interface to contact current maintainer.
+# Contributor: Trizen <echo dHJpemVueEBnbWFpbC5jb20K | base64 -d>
+# Generator : CPANPLUS::Dist::Arch 1.32
-_author=PJACKLAM
-_perlmod=Math-BigInt-GMP
-pkgname=perl-math-bigint-gmp
-pkgver=1.6004
-pkgrel=1
-pkgdesc="Big integer calculations using the GNU Multiple Precision Arithmetic Library."
+pkgname='perl-math-bigint-gmp'
+pkgver='1.6004'
+pkgrel='1'
+pkgdesc="Math::BigInt::GMP - backend library for Math::BigInt etc. based on GMP"
arch=('i686' 'x86_64')
-url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
-license=('GPL' 'PerlArtistic')
-depends=('perl>=5.22.1' 'gmp' 'perl-math-bigint>=1.999808')
-options=(!emptydirs)
-source=(http://cpan.perl.org/modules/by-authors/id/P/PJ/$_author/$_perlmod-$pkgver.tar.gz)
-sha256sums=('236229dd7d323f142d8b24b83d21061152432096be7aea026002b8dbbba733f2')
-
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('gmp>=6.1.2' 'perl>=5.6.1' 'perl-math-bigint>=1.999808')
+makedepends=()
+url='https://metacpan.org/release/Math-BigInt-GMP'
+source=("https://cpan.metacpan.org/authors/id/P/PJ/PJACKLAM/Math-BigInt-GMP-$pkgver.tar.gz")
+md5sums=('08a859a57c7512b1c92e57d717893154')
+sha512sums=('54b416fe577512691a97b9a06f8ca2ffc4ab63e0d11325f5926c42a4248b87325c2b5db0c57b2239819e863891ea40ab028b0f061ed9c8bbbf6886c467cb8d1e')
+_distdir="Math-BigInt-GMP-$pkgver"
build() {
- cd "$srcdir/$_perlmod-$pkgver"
- # Install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
}
check() {
- cd "$srcdir/$_perlmod-$pkgver"
- make test
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
}
package() {
- cd "$srcdir/$_perlmod-$pkgver"
- make install DESTDIR="$pkgdir/"
-
- find ${pkgdir} -name '.packlist' -delete
- find ${pkgdir} -name '*.pod' -delete
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-# vim:set ts=2 sw=2 et ft=sh:
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: