summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. A. López-Valencia2015-07-07 19:25:18 -0500
committerP. A. López-Valencia2015-07-07 19:25:18 -0500
commitbfa8637bcb6c3494c6762f80cb1e3d08b340e6c1 (patch)
tree734323dd8ecb577859f2efcff42ec16f91f6dd1c
downloadaur-bfa8637bcb6c3494c6762f80cb1e3d08b340e6c1.tar.gz
1.38-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD38
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..215f70d8a9c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-math-bigint-gmp
+ pkgdesc = Big integer calculations using the GNU Multiple Precision Arithmetic Library.
+ pkgver = 1.38
+ pkgrel = 1
+ url = http://search.cpan.org/~PJACKLAM/Math-BigInt-GMP-1.38/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.20.0
+ depends = gmp
+ options = !emptydirs
+ source = http://cpan.perl.org/modules/by-authors/id/P/PJ/PJACKLAM/Math-BigInt-GMP-1.38.tar.gz
+ sha256sums = 1ad0cac911a08f150c5e5a8286aec20de21c863bd27b8f002456cff11e086f15
+
+pkgname = perl-math-bigint-gmp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa9b07747604
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*~
+pkg/
+src/
+*.gz
+*.bz2
+*.xz
+*.lzo
+*.xz4
+*.tgz
+*.tbz
+*.txz
+*.tar
+*.jar
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b4fa4cd29b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# See AUR interface to contact current maintainer.
+
+_author=PJACKLAM
+_perlmod=Math-BigInt-GMP
+pkgname=perl-math-bigint-gmp
+pkgver=1.38
+pkgrel=1
+pkgdesc="Big integer calculations using the GNU Multiple Precision Arithmetic Library."
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.20.0' 'gmp')
+options=(!emptydirs)
+source=(http://cpan.perl.org/modules/by-authors/id/P/PJ/$_author/$_perlmod-$pkgver.tar.gz)
+sha256sums=('1ad0cac911a08f150c5e5a8286aec20de21c863bd27b8f002456cff11e086f15')
+
+
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make install DESTDIR="$pkgdir/"
+
+ find ${pkgdir} -name '.packlist' -delete
+ find ${pkgdir} -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et ft=sh: