summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2015-06-10 14:54:44 +0200
committerSwift Geek2015-06-10 14:54:44 +0200
commitc7ef7f5be30a357181cbe4d9e15c70368616132e (patch)
tree22a0e3fce3ddb2d4c6622bd9489cad596d7b723a
downloadaur-c7ef7f5be30a357181cbe4d9e15c70368616132e.tar.gz
AUR4 import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..deef28885182
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-math-convexhull-monotonechain
+ pkgdesc = Math::ConvexHull::MonotoneChain - Andrew's monotone chain algorithm for finding a convex hull in 2D
+ pkgver = 0.01
+ pkgrel = 1
+ url = https://metacpan.org/release/Math-ConvexHull-MonotoneChain/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/Math-ConvexHull-MonotoneChain-0.01.tar.gz
+ md5sums = eaac1a9350f914fea5bbce2029b95b57
+
+pkgname = perl-math-convexhull-monotonechain
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e5302f6d9a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Swift Geek <swiftgeek (at) gmail.com>
+pkgname=perl-math-convexhull-monotonechain
+pkgver=0.01
+pkgrel=1
+pkgdesc="Math::ConvexHull::MonotoneChain - Andrew's monotone chain algorithm for finding a convex hull in 2D"
+arch=('any')
+url="https://metacpan.org/release/Math-ConvexHull-MonotoneChain/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+#install=
+source=("http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/Math-ConvexHull-MonotoneChain-${pkgver}.tar.gz")
+md5sums=('eaac1a9350f914fea5bbce2029b95b57')
+
+prepare() {
+ export _src_dir="$srcdir/Math-ConvexHull-MonotoneChain-$pkgver"
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ cd "$_src_dir"
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check () {
+ cd "$_src_dir"
+ make test
+}
+
+package () {
+ cd "$_src_dir"
+ make install
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+