summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit265a1d9d0b5c888a96ca9c561e2fe363cccc8938 (patch)
tree1e1b04be4cc1552d88d40cf9105df205c09eefd2
downloadaur-265a1d9d0b5c888a96ca9c561e2fe363cccc8938.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--PKGBUILD.tt32
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3955dde5db42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-math-counting
+ pkgdesc = Perl module for combinatorial counting operations
+ pkgver = 0.1303
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Math-Counting
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>5.10.1
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/G/GE/GENE/Math-Counting-0.1303.tar.gz
+ md5sums = 108316c63bddff9b85345b4789142cc2
+
+pkgname = perl-math-counting
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7528e2dfac9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# CPAN Name : Math::Counting
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname=perl-math-counting
+pkgver=0.1303
+pkgrel=1
+pkgdesc='Perl module for combinatorial counting operations'
+arch=('any')
+url="http://search.cpan.org/dist/Math-Counting"
+license=('GPL' 'PerlArtistic')
+depends=('perl>5.10.1')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/G/GE/GENE/Math-Counting-0.1303.tar.gz)
+md5sums=('108316c63bddff9b85345b4789142cc2')
+
+build() {
+ cd "$srcdir/Math-Counting-0.1303"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/Math-Counting-0.1303"
+ make test
+}
+
+package() {
+ cd "$srcdir/Math-Counting-0.1303"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..ad4cdd95fd31
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : Math::Counting
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl module for combinatorial counting operations'
+arch=('any')
+url="[% url %]"
+license=('GPL' 'PerlArtistic')
+depends=('perl>5.10.1')
+options=(!emptydirs)
+source=([% source %])
+md5sums=('[% md5sums %]')
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}