summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2016-06-15 10:56:44 -0600
committerJohn D Jones III2016-06-15 10:56:44 -0600
commit4c97b50c07e76e20e6f9264661109f3244ffab9c (patch)
treee95928398e1c0c36343e7206900281fe4c1abec1
downloadaur-4c97b50c07e76e20e6f9264661109f3244ffab9c.tar.gz
The new Math Gradient
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5fd6f5c901c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Jun 15 16:56:29 UTC 2016
+pkgbase = perl-math-gradient
+ pkgdesc = Perl extension for calculating gradients for colour transitions, etc.
+ pkgver = 0.04
+ pkgrel = 1
+ url = https://metacpan.org/release/Math-Gradient
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CR/CRAKRJACK/Math-Gradient-0.04.tgz
+ md5sums = 4324edf09a8f684153ac0079f8507a0b
+ sha512sums = 84443d50bbfc51fe8d2314a1cbac158643845b5f9c948f6d5c8d9930cb920b8403211b5152a2aff6e5eb8fe5331656b9eee1304ee53de622967b8042f6d75aec
+
+pkgname = perl-math-gradient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8592caecd819
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-math-gradient'
+pkgver='0.04'
+pkgrel='1'
+pkgdesc="Perl extension for calculating gradients for colour transitions, etc."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/Math-Gradient'
+source=('http://search.cpan.org/CPAN/authors/id/C/CR/CRAKRJACK/Math-Gradient-0.04.tgz')
+md5sums=('4324edf09a8f684153ac0079f8507a0b')
+sha512sums=('84443d50bbfc51fe8d2314a1cbac158643845b5f9c948f6d5c8d9930cb920b8403211b5152a2aff6e5eb8fe5331656b9eee1304ee53de622967b8042f6d75aec')
+_distdir="Math-Gradient-0.04"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: