summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-07 11:13:07 +0300
committerAnton Leontiev2015-08-07 11:38:08 +0300
commitb439044ee042c0f8713a917b21925c499258600c (patch)
tree8b38b5f5f08f6c68b101c23363c900cd4b614851
parentf53196549d7de15eb614ca6971f0ce1cf028047d (diff)
downloadaur-b439044ee042c0f8713a917b21925c499258600c.tar.gz
Updated to v0.35
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--PKGBUILD.tt4
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efbc036b4b0f..223f86c0d04a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = perl-math-gsl
pkgdesc = Perl module providing interface to the GNU Scientific Library
- pkgver = 0.28
+ pkgver = 0.35
pkgrel = 1
- url = http://search.cpan.org/dist/Math-GSL
+ url = https://metacpan.org/release/Math-GSL
arch = i686
arch = x86_64
license = GPL
checkdepends = perl-test-exception
checkdepends = perl-test-class
checkdepends = perl-test-most
- makedepends = perl-extutils-pkgconfig
+ checkdepends = perl-test-taint
+ makedepends = perl-module-build
depends = perl
depends = gsl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/L/LE/LETO/Math-GSL-0.28.tar.gz
- md5sums = cb6a5d3b3fbc266060aeb4a8177a3fe7
+ source = http://search.cpan.org/CPAN/authors/id/A/AM/AMBS/Math-GSL-0.35.tar.gz
+ md5sums = b7d4cdb617db449a6d955e9aeeddb0aa
pkgname = perl-math-gsl
diff --git a/PKGBUILD b/PKGBUILD
index 1f95fef804f6..58093fac52fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
# CPAN Name : Math::GSL
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-math-gsl
-pkgver=0.28
+pkgver=0.35
pkgrel=1
pkgdesc='Perl module providing interface to the GNU Scientific Library'
arch=('i686' 'x86_64')
-url='http://search.cpan.org/dist/Math-GSL'
+url='https://metacpan.org/release/Math-GSL'
license=('GPL')
options=(!emptydirs)
depends=('perl' 'gsl')
-makedepends=('perl-extutils-pkgconfig')
-checkdepends=('perl-test-exception' 'perl-test-class' 'perl-test-most')
-source=(http://search.cpan.org/CPAN/authors/id/L/LE/LETO/Math-GSL-0.28.tar.gz)
-md5sums=('cb6a5d3b3fbc266060aeb4a8177a3fe7')
+makedepends=('perl-module-build')
+checkdepends=('perl-test-exception' 'perl-test-class' 'perl-test-most' 'perl-test-taint')
+source=(http://search.cpan.org/CPAN/authors/id/A/AM/AMBS/Math-GSL-0.35.tar.gz)
+md5sums=('b7d4cdb617db449a6d955e9aeeddb0aa')
build() {
- cd Math-GSL-0.28
+ cd Math-GSL-0.35
PERL_MM_USE_DEFAULT=1 perl Build.PL --installdirs vendor --destdir "$pkgdir"
perl Build
}
check() {
- cd Math-GSL-0.28
+ cd Math-GSL-0.35
perl Build test
}
package() {
- cd Math-GSL-0.28
+ cd Math-GSL-0.35
perl Build install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index a655d3c6b326..d1ebfc5b1c78 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -11,8 +11,8 @@ url='[% url %]'
license=('GPL')
options=(!emptydirs)
depends=('perl' 'gsl')
-makedepends=('perl-extutils-pkgconfig')
-checkdepends=('perl-test-exception' 'perl-test-class' 'perl-test-most')
+makedepends=('perl-module-build')
+checkdepends=('perl-test-exception' 'perl-test-class' 'perl-test-most' 'perl-test-taint')
source=([% source %])
md5sums=('[% md5sums %]')