summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2017-02-28 02:09:52 +0100
committerSebastian 'Swift Geek' Grzywna2017-02-28 02:09:52 +0100
commit482abb2a9286b384f8278001a3a249de15b75a4e (patch)
tree4ae4b841414daf7204c78a8b833f5487fb9472df
parenta607f442b51016dc8f9534a3f987f8e829e83aac (diff)
downloadaur-perl-math-libm.tar.gz
Fix use with makepkg -e and -o options
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b4c07fb645b..d58547b98d64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Tue Feb 28 01:09:52 UTC 2017
pkgbase = perl-math-libm
pkgdesc = Math::Libm - Perl extension for the C math library, libm
pkgver = 1.00
diff --git a/PKGBUILD b/PKGBUILD
index b2b989410467..98d8bc5a974d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,29 +16,26 @@ options=(!emptydirs)
install=
source=("http://search.cpan.org/CPAN/authors/id/D/DS/DSLEWART/Math-Libm-${pkgver}.tar.gz")
md5sums=('26a4ce8fe507d04c7d40b9eadac428ae')
+_src_dir='$srcdir/Math-Libm-$pkgver'
-prepare() {
- export _src_dir="$srcdir/Math-Libm-$pkgver"
+build() {
# Setting these env variables overwrites any command-line-options we don't want...
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
-}
-
-build() {
- cd "$_src_dir"
+ eval cd "$_src_dir"
/usr/bin/perl Makefile.PL
make
}
check () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
make test
}
package () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
make install
# remove perllocal.pod and .packlist