summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2015-06-10 14:57:28 +0200
committerSwift Geek2015-06-10 14:57:28 +0200
commita607f442b51016dc8f9534a3f987f8e829e83aac (patch)
tree8f0550a86f1e92f24a8e3831b3d07b96bfdde8f2
downloadaur-a607f442b51016dc8f9534a3f987f8e829e83aac.tar.gz
AUR4 import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b4c07fb645b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-math-libm
+ pkgdesc = Math::Libm - Perl extension for the C math library, libm
+ pkgver = 1.00
+ pkgrel = 1
+ url = https://metacpan.org/release/Math-Libm/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DS/DSLEWART/Math-Libm-1.00.tar.gz
+ md5sums = 26a4ce8fe507d04c7d40b9eadac428ae
+
+pkgname = perl-math-libm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2b989410467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Swift Geek <swiftgeek «at» gmail.com>
+pkgname=perl-math-libm
+pkgver=1.00
+pkgrel=1
+pkgdesc="Math::Libm - Perl extension for the C math library, libm"
+arch=('any')
+url="https://metacpan.org/release/Math-Libm/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://search.cpan.org/CPAN/authors/id/D/DS/DSLEWART/Math-Libm-${pkgver}.tar.gz")
+md5sums=('26a4ce8fe507d04c7d40b9eadac428ae')
+
+prepare() {
+ export _src_dir="$srcdir/Math-Libm-$pkgver"
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ cd "$_src_dir"
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check () {
+ cd "$_src_dir"
+ make test
+}
+
+package () {
+ cd "$_src_dir"
+ make install
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+