summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiernov2024-02-14 11:24:00 +0100
committerpiernov2024-02-14 11:24:50 +0100
commit8072b36e5994f30a9d57b49585c955c2dce8466c (patch)
tree732f59dbd2e754b8374d284de8e4c5637409cf97
parentbef077a1a488c0a44a69c1ac2e221b069cb98b8f (diff)
downloadaur-8072b36e5994f30a9d57b49585c955c2dce8466c.tar.gz
perl-mime-lite-html 1.24-2: add fix_random_ftbfs_testsuite.patch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--fix_random_ftbfs_testsuite.patch37
3 files changed, 46 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efc6f94ce4b6..873f700984f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-mime-lite-html
pkgdesc = Perl module that provides routine to transform a HTML page in a MIME-Lite mail
pkgver = 1.24
- pkgrel = 1
+ pkgrel = 2
url = http://search.cpan.org/dist/MIME-Lite-HTML/
arch = any
license = GPL
@@ -12,8 +12,9 @@ pkgbase = perl-mime-lite-html
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/A/AL/ALIAN/MIME-Lite-HTML-1.24.tar.gz
source = fix_perl_hash_seed_issues.patch
+ source = fix_random_ftbfs_testsuite.patch
md5sums = 6ca475aaa73328f8c51b7002d828fe7e
md5sums = be20c7145fd5421c4e533ff80ebf6169
+ md5sums = 77d07411e97aaf0e9f8bf0c578cce7e6
pkgname = perl-mime-lite-html
-
diff --git a/PKGBUILD b/PKGBUILD
index 5e94bc11c864..eb15aa2be3a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=perl-mime-lite-html
pkgver=1.24
-pkgrel=1
+pkgrel=2
pkgdesc="Perl module that provides routine to transform a HTML page in a MIME-Lite mail"
arch=('any')
url="http://search.cpan.org/dist/MIME-Lite-HTML/"
@@ -10,13 +10,16 @@ license=('GPL')
depends=('perl' 'perl-mime-lite' 'perl-libwww' 'perl-html-parser')
options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/A/AL/ALIAN/MIME-Lite-HTML-${pkgver}.tar.gz"
- "fix_perl_hash_seed_issues.patch")
+ "fix_perl_hash_seed_issues.patch"
+ "fix_random_ftbfs_testsuite.patch")
md5sums=('6ca475aaa73328f8c51b7002d828fe7e'
- 'be20c7145fd5421c4e533ff80ebf6169')
+ 'be20c7145fd5421c4e533ff80ebf6169'
+ '77d07411e97aaf0e9f8bf0c578cce7e6')
build() {
cd MIME-Lite-HTML-${pkgver}
patch -p1 -i "${srcdir}/fix_perl_hash_seed_issues.patch"
+ patch -p1 -i "${srcdir}/fix_random_ftbfs_testsuite.patch"
perl Makefile.PL INSTALLDIRS=vendor
make
}
diff --git a/fix_random_ftbfs_testsuite.patch b/fix_random_ftbfs_testsuite.patch
new file mode 100644
index 000000000000..c1283ee2f983
--- /dev/null
+++ b/fix_random_ftbfs_testsuite.patch
@@ -0,0 +1,37 @@
+Description: Fix random FTBFS in test suite with the approximative size factor
+ which can be too small in some cases
+Author: Emmanuel Bouthenot <kolter@debian.org>
+Bug-Debian: https://bugs.debian.org/844911
+Forwarded: no
+Last-Update: 2016-11-24
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/t/50generic.t
++++ b/t/50generic.t
+@@ -51,7 +51,7 @@
+ close(PROD);
+ my $r = `diff $ref $f.created_by_test`;
+ cmp_ok($mailHTML->size, ">", (stat($ref))[7], "Same size");
+- cmp_ok($mailHTML->size*0.945, "<", (stat($ref))[7], "Same size");
++ cmp_ok($mailHTML->size*0.943, "<", (stat($ref))[7], "Same size");
+ is($r, "", $ref);
+ unlink("$f.created_by_test");
+ }
+@@ -92,7 +92,7 @@
+ close(PROD);
+ my $r = `diff $ref $f.created_by_test`;
+ cmp_ok($mailHTML->size, ">", (stat($ref))[7], "Same size");
+- cmp_ok($mailHTML->size*0.945, "<", (stat($ref))[7], "Same size");
++ cmp_ok($mailHTML->size*0.943, "<", (stat($ref))[7], "Same size");
+ is($r, "", $ref);
+ unlink("$f.created_by_test");
+ }
+@@ -134,7 +134,7 @@
+ close(PROD);
+ my $r = `diff $ref $f.created_by_test`;
+ cmp_ok($mailHTML->size, ">", (stat($ref))[7], "Same size");
+- cmp_ok($mailHTML->size*0.945, "<", (stat($ref))[7], "Same size");
++ cmp_ok($mailHTML->size*0.943, "<", (stat($ref))[7], "Same size");
+ is($r, "", $ref);
+ unlink("$f.created_by_test");
+ }