summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrás Wacha2016-11-09 08:48:20 +0100
committerAndrás Wacha2016-11-09 08:48:20 +0100
commita82c0bbd0db01a422d20d5efec8608c6505e6e2f (patch)
tree4625511b1600d3c14a9527bba3ad5f0b677d8453
downloadaur-a82c0bbd0db01a422d20d5efec8608c6505e6e2f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD49
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24de540365fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-module-compile
+ pkgdesc = Perl Module Compilation
+ pkgver = 0.35
+ pkgrel = 1
+ url = https://metacpan.org/release/Module-Compile
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-digest-sha1>=2.13
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/I/IN/INGY/Module-Compile-0.35.tar.gz
+ md5sums = 7b9cf30692ab350d2ac013db55d9bc34
+ sha512sums = 4115277ffb0da033c6c7fea6480c7245c8b5eb151378081fefaef35761b92a4218d56e8e1e9a4892ce78a379592336badefa2de56062d9e5b7024cdc35d3e46b
+
+pkgname = perl-module-compile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd6ad2726234
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.tar.gz
+*.pkg.tar.xz
+*~
+*.log \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99f8dd8dba22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Generator : CPANPLUS::Dist::Arch 1.32
+# Maintainer: András Wacha < awacha at gmail >
+
+pkgname='perl-module-compile'
+pkgver='0.35'
+pkgrel='1'
+pkgdesc="Perl Module Compilation"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-digest-sha1>=2.13')
+makedepends=()
+url='https://metacpan.org/release/Module-Compile'
+source=('http://search.cpan.org/CPAN/authors/id/I/IN/INGY/Module-Compile-0.35.tar.gz')
+md5sums=('7b9cf30692ab350d2ac013db55d9bc34')
+sha512sums=('4115277ffb0da033c6c7fea6480c7245c8b5eb151378081fefaef35761b92a4218d56e8e1e9a4892ce78a379592336badefa2de56062d9e5b7024cdc35d3e46b')
+_distdir="Module-Compile-0.35"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: