summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Ziebarth2016-04-13 14:58:51 +0200
committerSebastian Ziebarth2016-04-13 14:58:51 +0200
commitcb0e8f21def1a0ddadba2c75eca19339379b3b2a (patch)
treec4848a0b6b072e399d8811a5250793c2db60c3ac
downloadaur-cb0e8f21def1a0ddadba2c75eca19339379b3b2a.tar.gz
Initial commit for 1.17
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e70d38769972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-mogilefs-client
+ pkgdesc = Client library for the MogileFS distributed file system
+ pkgver = 1.17
+ pkgrel = 1
+ url = http://www.mogilefs.org/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-libwww
+ depends = perl-io-stringy
+ options = !emptydirs
+ source = http://cpan.perl.org/modules/by-authors/id/DORMANDO/MogileFS-Client-1.17.tar.gz
+ md5sums = f077c567fc29358ea6308f22a6ad76e5
+
+pkgname = perl-mogilefs-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5969ef844eae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sebastian Ziebarth <mauspacker@posteo.de>
+_author=DORMANDO
+_perlmod=MogileFS-Client
+pkgname=perl-mogilefs-client
+pkgver=1.17
+pkgrel=1
+pkgdesc="Client library for the MogileFS distributed file system"
+arch=(any)
+_dist="MogileFS-Client"
+url="http://www.mogilefs.org/"
+license=('GPL' 'PerlArtistic')
+depends=(perl-libwww perl-io-stringy)
+options=('!emptydirs')
+source=(http://cpan.perl.org/modules/by-authors/id/$_author/$_perlmod-$pkgver.tar.gz)
+md5sums=('f077c567fc29358ea6308f22a6ad76e5')
+
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make install DESTDIR="$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 et: