aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2015-09-25 08:17:44 -0400
committerMark Grimes2015-09-25 08:17:44 -0400
commit3e989fed9a9820cc06c62f4d4209b94737538dc8 (patch)
treeab5e7201da773eded111367004ea83eabba0531d
downloadaur-3e989fed9a9820cc06c62f4d4209b94737538dc8.tar.gz
Initial release v0.39 (replacement for Nagios::Plugin)
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD39
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d65f42ca9741
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = perl-nagios-plugin
+ pkgdesc = A family of perl modules to streamline writing Naemon, Nagios, Icinga or Shinken (and compatible) plugins.
+ pkgver = 0.39
+ pkgrel = 1
+ url = https://metacpan.org/module/Monitoring-Plugin
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ depends = perl-params-validate
+ depends = perl-class-accessor
+ depends = perl-config-tiny
+ depends = perl-math-calc-units
+ options = !emptydirs
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/N/NI/NIERLEIN/Monitoring-Plugin-0.39.tar.gz
+ md5sums = c786ada6289bda2c4380d3df3b5185d5
+
+pkgname = perl-nagios-plugin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..af160642e750
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.tar.gz
+*.src.tar.gz
+*.pkg.tar*
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b74118b78156
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mark Grimes <mgrimes at peculier.com>
+
+pkgname=perl-nagios-plugin
+pkgver=0.39
+pkgrel=1
+pkgdesc="A family of perl modules to streamline writing Naemon, Nagios, Icinga or Shinken (and compatible) plugins."
+_dist=Monitoring-Plugin
+arch=('any')
+url="https://metacpan.org/module/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' 'perl-params-validate' 'perl-class-accessor' 'perl-config-tiny' 'perl-math-calc-units')
+options=('!emptydirs' purge)
+source=(https://cpan.metacpan.org/authors/id/N/NI/NIERLEIN/$_dist-$pkgver.tar.gz)
+md5sums=('c786ada6289bda2c4380d3df3b5185d5')
+
+# Setup environment to ensure installation in system perl and vender directory
+clean_env() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null PERL_AUTOINSTALL=--skipdeps
+}
+
+build() (
+ cd "$srcdir/$_dist-$pkgver"
+ clean_env
+ /usr/bin/perl Makefile.PL
+ make
+)
+
+check() (
+ cd "$srcdir/$_dist-$pkgver"
+ clean_env
+ make test
+)
+
+package() (
+ cd "$srcdir/$_dist-$pkgver"
+ clean_env
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+)