aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Göbel2015-10-19 20:20:24 +0200
committerStefan Göbel2015-10-19 20:20:24 +0200
commita76f6673eaabd32b200a25a812f2cac35e739e5c (patch)
tree314a402462bada9cbd9ce37a64e11449d0a90bea
downloadaur-a76f6673eaabd32b200a25a812f2cac35e739e5c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
-rw-r--r--README4
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b553286ef49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-moosex-aliases
+ pkgdesc = Easy aliasing of methods and attributes in Moose.
+ pkgver = 0.11
+ pkgrel = 1
+ url = https://metacpan.org/release/MooseX-Aliases
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-moose
+ checkdepends = perl-test-fatal
+ depends = perl-moose>=2.0000
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DO/DOY/MooseX-Aliases-0.11.tar.gz
+ md5sums = 78376310deba54ca644292d44566cefa
+
+pkgname = perl-moosex-aliases
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc6825dc2802
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
+
+pkgname='perl-moosex-aliases'
+_module='MooseX-Aliases'
+_author='D/DO/DOY'
+pkgver='0.11'
+pkgrel='1'
+pkgdesc='Easy aliasing of methods and attributes in Moose.'
+arch=('any')
+url="https://metacpan.org/release/$_module"
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-moose>=2.0000')
+checkdepends=('perl-moose' 'perl-test-fatal')
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_module-$pkgver.tar.gz")
+md5sums=('78376310deba54ca644292d44566cefa')
+
+build() {
+ (
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1' PERL_AUTOINSTALL='--skipdeps'
+ cd "$_module-$pkgver"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1'
+ make test
+ )
+}
+
+package() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS='vendor' DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ )
+}
+
+#:indentSize=3:tabSize=3:noTabs=true:mode=shellscript:maxLineLen=87: \ No newline at end of file
diff --git a/README b/README
new file mode 100644
index 000000000000..3564714d7779
--- /dev/null
+++ b/README
@@ -0,0 +1,4 @@
+This repository contains the PKGBUILD to create the «perl-moosex-aliases»
+package for the Perl module MooseX::Aliases for Arch Linux.
+
+See https://aur.archlinux.org/packages/perl-moosex-aliases/. \ No newline at end of file