summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy Will2018-10-21 20:33:36 -0700
committerTroy Will2018-10-21 20:33:36 -0700
commit8d54e937acd42847547271215bdc3b3c3b8d69d3 (patch)
tree10c1759e2c747a0e49781114ee0638bc7c859e29
downloadaur-8d54e937acd42847547271215bdc3b3c3b8d69d3.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8578c641f17f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-moosex-followpbp
+ pkgdesc = This packages the Foo-Bar distribution, containing the Foo::Bar module!
+ pkgver = 0.05
+ pkgrel = 1
+ url = https://metacpan.org/release/MooseX-FollowPBP
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/MooseX-FollowPBP-0.05.tar.gz
+ md5sums = 6d62fe9be745bba23748290978f89caa
+
+pkgname = perl-moosex-followpbp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d54ef041db05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Troy Will <.com gmail AT troydwill>
+pkgname=perl-moosex-followpbp
+pkgver=0.05
+pkgrel=1
+pkgdesc='This packages the Foo-Bar distribution, containing the Foo::Bar module!'
+_dist=MooseX-FollowPBP
+_author=D/DR/DROLSKY
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/$_author/$_dist-$pkgver.tar.gz")
+md5sums=(6d62fe9be745bba23748290978f89caa)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}