summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:32:19 -0600
committerJohn D Jones III2015-06-16 15:32:19 -0600
commit3832f450e6cd4f6cec249ba2d09377c4e80c596e (patch)
tree16116d65e7849cfba5f24549ce7a1934cc161ec1
downloadaur-3832f450e6cd4f6cec249ba2d09377c4e80c596e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a295ea434a18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-mp3-tag
+ pkgdesc = Module for reading tags of MP3 audio files
+ pkgver = 1.13
+ pkgrel = 1
+ url = http://search.cpan.org/dist/MP3-Tag
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/I/IL/ILYAZ/modules/MP3-Tag-1.13.tar.gz
+ md5sums = 1eea17c9c8a03433634eb37fc16311d3
+ sha512sums = 3dcdc186d8e2f00fc474eccadb755058fcba6cb80637c87d8565981f073bb19fa867a755de7423e3d58393bc730fe85f601f63dd928f4fe27a9fe9b80f63bfc3
+
+pkgname = perl-mp3-tag
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6ac4d5e5dde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-mp3-tag'
+pkgver='1.13'
+pkgrel='1'
+pkgdesc="Module for reading tags of MP3 audio files"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/MP3-Tag'
+source=('http://search.cpan.org/CPAN/authors/id/I/IL/ILYAZ/modules/MP3-Tag-1.13.tar.gz')
+md5sums=('1eea17c9c8a03433634eb37fc16311d3')
+sha512sums=('3dcdc186d8e2f00fc474eccadb755058fcba6cb80637c87d8565981f073bb19fa867a755de7423e3d58393bc730fe85f601f63dd928f4fe27a9fe9b80f63bfc3')
+_distdir="MP3-Tag-1.13"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: