summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJimmy Xu2023-11-12 18:19:05 +0000
committerJimmy Xu2023-11-12 18:19:05 +0000
commit9a31bbc3244c3dccea074eb54bf70f461a0b107f (patch)
tree50925610972e83c4be011f80055c7d150d56dd7f
parente5b8940e8a23c974427317ad28fdce98d085cc15 (diff)
downloadaur-9a31bbc3244c3dccea074eb54bf70f461a0b107f.tar.gz
perl-net-dns-paranoid: 0.08-2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--t-xip.io.patch36
3 files changed, 45 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d8fceff4a9c..e9f1b7e31566 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-net-dns-paranoid
pkgdesc = paranoid dns resolver
pkgver = 0.08
- pkgrel = 1
+ pkgrel = 2
url = http://search.cpan.org/dist/Net-DNS-Paranoid
arch = any
license = GPL
@@ -12,7 +12,8 @@ pkgbase = perl-net-dns-paranoid
depends = perl-net-dns
options = !emptydirs
source = http://cpan.perl.org/modules/by-module/Net/Net-DNS-Paranoid-0.08.tar.gz
+ source = t-xip.io.patch
sha256sums = db359ba7c490405456db465e4d7ecb9622326d9b00e59a7914dbbb2bd554784a
+ sha256sums = 3a81e3143e74acee154f4b7572b838899499297be2bb3f080cb793a06de6e45a
pkgname = perl-net-dns-paranoid
-
diff --git a/PKGBUILD b/PKGBUILD
index 91dce0fad7a6..83e0c829e82e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _perlmod='Net-DNS-Paranoid'
_modnamespace=Net
pkgname=perl-net-dns-paranoid
pkgver=0.08
-pkgrel=1
+pkgrel=2
pkgdesc="paranoid dns resolver"
arch=("any")
url="http://search.cpan.org/dist/$_perlmod"
@@ -12,11 +12,14 @@ license=('GPL' 'PerlArtistic')
depends=('perl' 'perl-class-accessor-lite' 'perl-net-dns')
makedepends=('perl-module-build')
options=('!emptydirs')
-source=("http://cpan.perl.org/modules/by-module/$_modnamespace/$_perlmod-$pkgver.tar.gz")
-sha256sums=('db359ba7c490405456db465e4d7ecb9622326d9b00e59a7914dbbb2bd554784a')
+source=("http://cpan.perl.org/modules/by-module/$_modnamespace/$_perlmod-$pkgver.tar.gz"
+ t-xip.io.patch)
+sha256sums=('db359ba7c490405456db465e4d7ecb9622326d9b00e59a7914dbbb2bd554784a'
+ '3a81e3143e74acee154f4b7572b838899499297be2bb3f080cb793a06de6e45a')
build() {
cd "$srcdir/$_perlmod-$pkgver"
+ patch -p1 -i "$srcdir"/t-xip.io.patch
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
diff --git a/t-xip.io.patch b/t-xip.io.patch
new file mode 100644
index 000000000000..a44952266470
--- /dev/null
+++ b/t-xip.io.patch
@@ -0,0 +1,36 @@
+From 2d84b68bcdcf1325ba15d6d0252894d828a0d765 Mon Sep 17 00:00:00 2001
+From: Graham TerMarsch <graham@howlingfrog.com>
+Date: Mon, 30 Aug 2021 13:14:00 -0700
+Subject: [PATCH] Switch to `nip.io`, from `xip.io` in this test.
+
+`xip.io` stopped working long ago, and `nip.io` provides a similar
+service and should be working. Update test accordingly.
+
+Resolves #4
+---
+ t/01_simple.t | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/t/01_simple.t b/t/01_simple.t
+index a121363..65f5132 100644
+--- a/t/01_simple.t
++++ b/t/01_simple.t
+@@ -78,15 +78,15 @@ subtest "can't do decimal/octal IPs" => sub {
+ [ undef, 'DNS lookup resulted in bad host.' ] );
+ };
+
+-subtest "this domain is okay. 50.112.116.235.xip.io isn't blocked" => sub {
+- is_deeply( [ $dns->resolve('50.112.116.235.xip.io') ],
++subtest "this domain is okay. 50.112.116.235.nip.io isn't blocked" => sub {
++ is_deeply( [ $dns->resolve('50.112.116.235.nip.io') ],
+ [ ['50.112.116.235'], undef ] );
+ };
+
+ subtest 'internal. bad. blocked by default by module.' => sub {
+ is_deeply( [ $dns->resolve('10.2.3.4') ],
+ [ undef, 'DNS lookup resulted in bad host.' ] );
+- is_deeply( [ $dns->resolve('50.112.116.235.xip.io') ],
++ is_deeply( [ $dns->resolve('50.112.116.235.nip.io') ],
+ [ ['50.112.116.235'], undef ], 'ok' );
+ };
+