summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit635ebc55aa7697d50bc5b2cc8a34bb68593020a7 (patch)
tree01ff570bc40d169b6517507d58e5e2725ce08fc1
downloadaur-635ebc55aa7697d50bc5b2cc8a34bb68593020a7.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..449a3fc7b0d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-net-mpd
+ pkgdesc = a lightweight replacment for Audio::MPD
+ pkgver = 0.05
+ pkgrel = 2
+ url = http://search.cpan.org/dist/Net-MPD/
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-harness>=3.29
+ makedepends = perl-module-build
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AB/ABERNDT/Net-MPD-0.05.tar.gz
+ sha256sums = 38d631633ad6380ec0790aedc31d20f0ec2a268809af71eb9041fb93eaec5989
+
+pkgname = perl-net-mpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a758e5093344
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Mantainer: 3ED <krzysztof1987 at gmail dot com>
+
+pkgname=perl-net-mpd
+_lastauthor=A/AB/ABERNDT
+_pkgname=Net-MPD
+pkgver=0.05
+pkgrel=2
+pkgdesc="a lightweight replacment for Audio::MPD"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=('perl-module-build')
+checkdepends=('perl-test-harness>=3.29')
+url="http://search.cpan.org/dist/${_pkgname}/"
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('38d631633ad6380ec0790aedc31d20f0ec2a268809af71eb9041fb93eaec5989')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Build.PL
+ perl Build
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Build test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Build install
+}