summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 11:12:18 -0600
committerBrian Bidulock2015-06-10 11:12:18 -0600
commit0f33feec70ad905bee45a8ed57fbc7d4ec015857 (patch)
treeb9dada8fb324b2adfe25c8b642e03d766f5a2516
downloadaur-0f33feec70ad905bee45a8ed57fbc7d4ec015857.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..757824a264c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-net-pcaputils
+ pkgdesc = Perl/CPAN Module Net::PcapUtils
+ pkgver = 0.01
+ pkgrel = 3
+ url = https://metacpan.org/release/Net-PcapUtils
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-net-pcap
+ options = !emptydirs
+ source = http://cpan.metacpan.org/authors/id/T/TI/TIMPOTTER/Net-PcapUtils-0.01.tar.gz
+ md5sums = eeba67266dbe155b504df3c2de1d657f
+
+pkgname = perl-net-pcaputils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b5d9f2c3701
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Alessandro Nakamuta <alessandro dot nakamuta at archlinux dot com dot br>
+
+pkgname=perl-net-pcaputils
+_cpanname=Net-PcapUtils
+pkgver=0.01
+pkgrel=3
+pkgdesc="Perl/CPAN Module Net::PcapUtils"
+arch=('any')
+url="https://metacpan.org/release/$_cpanname"
+license=("GPL" "PerlArtistic")
+options=('!emptydirs')
+source=("http://cpan.metacpan.org/authors/id/T/TI/TIMPOTTER/${_cpanname}-${pkgver}.tar.gz")
+depends=('perl-net-pcap')
+md5sums=('eeba67266dbe155b504df3c2de1d657f')
+
+build() {
+ cd "${srcdir}/${_cpanname}-${pkgver}"
+
+ # install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package() {
+ cd "${srcdir}/${_cpanname}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
+}