summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 11:15:18 -0600
committerBrian Bidulock2015-06-10 11:15:18 -0600
commit0d9b73e9ab2343741873f134f56c78f45ee8ba30 (patch)
tree25b07650db35b8a776c24ef5be0ab8bf4323ae64
downloadaur-0d9b73e9ab2343741873f134f56c78f45ee8ba30.tar.gz
initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd62de7415a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-net-write
+ pkgdesc = Net::Write - a portable interface to open and send raw data to network
+ pkgver = 1.07
+ pkgrel = 1
+ url = https://metacpan.org/release/Net-Write
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-class-gomor
+ depends = perl-socket6
+ depends = perl-net-pcap>=0.12
+ options = !emptydirs
+ source = http://cpan.metacpan.org/authors/id/G/GO/GOMOR/Net-Write-1.07.tar.gz
+ md5sums = a3310df977446fcd8004fdbb66a782b5
+
+pkgname = perl-net-write
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83ffb8b735d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Pranay Kanwar <pranay.kanwar@gmail.com>
+
+pkgname=perl-net-write
+_cpanname=Net-Write
+_module=Net::Write
+pkgver=1.07
+pkgrel=1
+pkgdesc="$_module - a portable interface to open and send raw data to network"
+arch=('any')
+url="https://metacpan.org/release/${_cpanname}"
+license=('GPL' 'PerlArtistic')
+depends=('perl-class-gomor' 'perl-socket6' 'perl-net-pcap>=0.12')
+options=('!emptydirs')
+source=("http://cpan.metacpan.org/authors/id/G/GO/GOMOR/${_cpanname}-${pkgver}.tar.gz")
+md5sums=('a3310df977446fcd8004fdbb66a782b5')
+
+build() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -o -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: