summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:38:48 -0600
committerJohn D Jones III2015-06-16 15:38:48 -0600
commitb0bc25899a9ca5251d1d09a7e8fa57b53468b74d (patch)
treeeb5a758406e0725d34754bc883d39b0bb0791c80
downloadaur-b0bc25899a9ca5251d1d09a7e8fa57b53468b74d.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7115cfcbe8a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-newt
+ pkgdesc = Perl bindings for RedHat newt library
+ pkgver = 1.08
+ pkgrel = 5
+ url = http://search.cpan.org/dist/Newt
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AM/AMEDINA/Newt-1.08.tar.gz
+ md5sums = 462f3fabc05ec5dd4a2d554c01568bdf
+ sha512sums = 98460f314c03cb9e4bf0d81ff178319a28b2fcba70daff2ce05c0c25abf26da4a5e7e4947361d2c849abbf7ffdab2f0e9f19f7c9174ff9018141f9ccd2b38b04
+
+pkgname = perl-newt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64bc3e59ea8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-newt'
+pkgver='1.08'
+pkgrel='5'
+pkgdesc="Perl bindings for RedHat newt library"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Newt'
+source=('http://search.cpan.org/CPAN/authors/id/A/AM/AMEDINA/Newt-1.08.tar.gz')
+md5sums=('462f3fabc05ec5dd4a2d554c01568bdf')
+sha512sums=('98460f314c03cb9e4bf0d81ff178319a28b2fcba70daff2ce05c0c25abf26da4a5e7e4947361d2c849abbf7ffdab2f0e9f19f7c9174ff9018141f9ccd2b38b04')
+_distdir="Newt-1.08"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: