summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2022-07-02 21:15:20 +0200
committerAlad Wenter2022-07-02 21:16:01 +0200
commit0b107aab8e7c2ca1a06b9f45c8dfafca058186fe (patch)
treebedf717a6b7f726bd22efc6b37a9c30471a5fd16
parent0bdb529886912ba6126e049dd363cc6fe036b4c2 (diff)
downloadaur-0b107aab8e7c2ca1a06b9f45c8dfafca058186fe.tar.gz
perl-orlite: fix tests, add perl-module-install makedepend
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--fix_tests.patch60
3 files changed, 79 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb12300cbd4f..15478ad38a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = perl-orlite
pkgdesc = ORLite - Extremely light weight SQLite-specific ORM
pkgver = 1.98
- pkgrel = 2
+ pkgrel = 3
url = http://search.cpan.org/dist/ORLite
arch = any
license = GPL
license = PerlArtistic
makedepends = perl-test-script
+ makedepends = perl-module-install
depends = perl-file-remove
depends = perl-dbd-sqlite
depends = perl-params-util
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/ORLite-1.98.tar.gz
- md5sums = 25912f777daf95114e10f4b3e3a3c35a
+ source = fix_tests.patch
+ sha256sums = 79e9ef07dee7feb7cafdea1a9c0432e12587fc350707a6bc72fd29502b87d021
+ sha256sums = f5135d9dab28d8163e418428af346b1d9484f8513d8874c65bd3eddfe4491a97
pkgname = perl-orlite
-
diff --git a/PKGBUILD b/PKGBUILD
index e4b54de7ec17..42d7106f0315 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Maintainer: Alad Wenter <alad at archlinux dot org>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
# Contributor: Jonathas Rodrigues
# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
@@ -6,21 +7,23 @@ _author=A/AD/ADAMK
_perlmod=ORLite
pkgname=perl-orlite
pkgver=1.98
-pkgrel=2
+pkgrel=3
pkgdesc='ORLite - Extremely light weight SQLite-specific ORM'
arch=('any')
url="http://search.cpan.org/dist/ORLite"
license=('GPL' 'PerlArtistic')
-depends=(
-perl-file-remove
-perl-dbd-sqlite
-perl-params-util
-)
-makedepends=(
-perl-test-script
-)
+depends=(perl-file-remove perl-dbd-sqlite perl-params-util )
+makedepends=(perl-test-script perl-module-install)
options=(!emptydirs)
-source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz"
+ "fix_tests.patch")
+sha256sums=('79e9ef07dee7feb7cafdea1a9c0432e12587fc350707a6bc72fd29502b87d021'
+ 'f5135d9dab28d8163e418428af346b1d9484f8513d8874c65bd3eddfe4491a97')
+
+prepare() {
+ cd "$srcdir"/$_perlmod-$pkgver
+ patch -p1 < "$srcdir"/fix_tests.patch
+}
build(){
cd "$srcdir"/$_perlmod-$pkgver
@@ -66,4 +69,3 @@ package(){
# remove perllocal.pod and .packlist
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-md5sums=('25912f777daf95114e10f4b3e3a3c35a')
diff --git a/fix_tests.patch b/fix_tests.patch
new file mode 100644
index 000000000000..2952eafd6ba3
--- /dev/null
+++ b/fix_tests.patch
@@ -0,0 +1,60 @@
+diff -u ORLite-1.98/t/02_basics.t.orig ORLite-1.98/t/02_basics.t
+--- ORLite-1.98/t/02_basics.t.orig 2012-10-01 00:48:41.000000000 +0200
++++ ORLite-1.98/t/02_basics.t 2022-07-02 20:43:19.248705932 +0200
+@@ -64,7 +64,7 @@
+ name => 'col1',
+ notnull => 1,
+ pk => 1,
+- type => 'integer',
++ type => 'INTEGER',
+ },
+ {
+ cid => 1,
+diff -u ORLite-1.98/t/10_cleanup.t.orig ORLite-1.98/t/10_cleanup.t
+--- ORLite-1.98/t/10_cleanup.t.orig 2012-10-01 00:48:41.000000000 +0200
++++ ORLite-1.98/t/10_cleanup.t 2022-07-02 20:41:31.369658211 +0200
+@@ -29,7 +29,7 @@
+ use strict;
+ use ORLite {
+ file => '$file',
+- cleanup => 'VACUUM ANALYZE',
++ cleanup => 'VACUUM; ANALYZE',
+ };
+
+ 1;
+diff -u ORLite-1.98/t/11_cleanup.t.orig ORLite-1.98/t/11_cleanup.t
+--- ORLite-1.98/t/11_cleanup.t.orig 2012-10-01 00:48:41.000000000 +0200
++++ ORLite-1.98/t/11_cleanup.t 2022-07-02 20:42:47.658984575 +0200
+@@ -29,7 +29,7 @@
+ use strict;
+ use ORLite {
+ file => '$file',
+- cleanup => 'VACUUM ANALYZE',
++ cleanup => 'VACUUM; ANALYZE',
+ };
+
+ 1;
+diff -u ORLite-1.98/t/19_view.t.orig ORLite-1.98/t/19_view.t
+--- ORLite-1.98/t/19_view.t.orig 2012-10-01 00:48:41.000000000 +0200
++++ ORLite-1.98/t/19_view.t 2022-07-02 20:45:28.097570974 +0200
+@@ -53,7 +53,7 @@
+ name => 'col1',
+ notnull => 0,
+ pk => 0,
+- type => 'integer',
++ type => 'INTEGER',
+ },
+ {
+ cid => 1,
+diff -u ORLite-1.98/t/21_normalize.t.orig ORLite-1.98/t/21_normalize.t
+--- ORLite-1.98/t/21_normalize.t.orig 2012-10-01 00:48:41.000000000 +0200
++++ ORLite-1.98/t/21_normalize.t 2022-07-02 20:45:28.097570974 +0200
+@@ -66,7 +66,7 @@
+ name => 'columnID',
+ notnull => 1,
+ pk => 1,
+- type => 'integer',
++ type => 'INTEGER',
+ },
+ {
+ cid => 1,