summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-11-10 16:54:07 +0400
committerAnton Leontiev2015-02-15 07:48:19 +0300
commit4ba8c0eccc17e5c30bcbe3e804b64403486f764f (patch)
tree3e904cc126e744911890e4a408e3ff50913413bf
parent007c6f83b1a8a5ba9ce7eb808abc76a3bcd9759d (diff)
downloadaur-4ba8c0eccc17e5c30bcbe3e804b64403486f764f.tar.gz
Updated to v0.0408
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--PKGBUILD.tt18
3 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7a00b3bfd35..d4b5ff60d1ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = perl-ouch
pkgdesc = Perl module for exceptions that don't hurt
- pkgver = 0.0405
+ pkgver = 0.0408
pkgrel = 1
url = http://search.cpan.org/dist/Ouch
arch = any
license = PerlArtistic
license = GPL
checkdepends = perl-test-trap
- depends = perl
+ depends = perl>=5.10.1
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/R/RI/RIZEN/Ouch-0.0405.tar.gz
- md5sums = 6fd3a410e40d20244de4d67fe5b08037
+ source = http://search.cpan.org/CPAN/authors/id/R/RI/RIZEN/Ouch-0.0408.tar.gz
+ md5sums = f3cd70271ba8f7598569bc04097b7881
pkgname = perl-ouch
diff --git a/PKGBUILD b/PKGBUILD
index ad99cc6316df..60b1859b93ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
# CPAN Name : Ouch
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Generator : CPANPLUS::Dist::Arch 1.28
pkgname=perl-ouch
-pkgver=0.0405
+pkgver=0.0408
pkgrel=1
pkgdesc="Perl module for exceptions that don't hurt"
arch=('any')
url='http://search.cpan.org/dist/Ouch'
license=('PerlArtistic' 'GPL')
-depends=('perl')
+depends=('perl>=5.10.1')
checkdepends=('perl-test-trap')
-source=(http://search.cpan.org/CPAN/authors/id/R/RI/RIZEN/Ouch-0.0405.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/R/RI/RIZEN/Ouch-0.0408.tar.gz)
options=(!emptydirs)
-md5sums=('6fd3a410e40d20244de4d67fe5b08037')
+md5sums=('f3cd70271ba8f7598569bc04097b7881')
build() {
- cd Ouch-0.0405
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd Ouch-0.0408
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd Ouch-0.0405
- make test
+ cd Ouch-0.0408
+ make test
}
package() {
- cd Ouch-0.0405
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd Ouch-0.0408
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 427dbea38dc8..31ee99c4e58d 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -9,25 +9,25 @@ pkgdesc="Perl module for exceptions that don't hurt"
arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
-depends=('perl')
+depends=('perl>=5.10.1')
checkdepends=('perl-test-trap')
source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
build() {
- cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd [% distdir %]
- make test
+ cd [% distdir %]
+ make test
}
package() {
- cd [% distdir %]
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}