summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:25:08 +0200
committerPiotr Rogoża2015-06-14 16:25:08 +0200
commitf03a81779bb932b5ee3ecc14ac84129d43644879 (patch)
tree80a0c5d50dbaab3aad1cb23b279eae2a1c841711
downloadaur-perl-parse-functions.tar.gz
Initial import
-rw-r--r--.AURINFO21
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD69
3 files changed, 112 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d485360a0ca1
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,21 @@
+pkgbase = perl-parse-functions
+ pkgdesc = Parse-Functions - list all the functions in source code
+ pkgver = 0.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Parse-Functions/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = perl
+ depends = perl
+ provides = perl-parse-functions-csharp
+ provides = perl-parse-functions-java
+ provides = perl-parse-functions-perl
+ provides = perl-parse-functions-python
+ provides = perl-parse-functions-ruby
+ source = http://search.cpan.org/CPAN/authors/id/S/SZ/SZABGAB/Parse-Functions-0.01.tar.gz
+ options = !emptydirs
+
+pkgname = perl-parse-functions
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21579b3c5898
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = perl-parse-functions
+ pkgdesc = Parse-Functions - list all the functions in source code
+ pkgver = 0.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Parse-Functions/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = perl
+ depends = perl
+ provides = perl-parse-functions-csharp
+ provides = perl-parse-functions-java
+ provides = perl-parse-functions-perl
+ provides = perl-parse-functions-python
+ provides = perl-parse-functions-ruby
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SZ/SZABGAB/Parse-Functions-0.01.tar.gz
+ sha256sums = ba1946d453b3273530c68dcfb41eb6b0a0d8053fe0496b4dc0e6b8a9b2f69900
+
+pkgname = perl-parse-functions
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a97547125da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Piotr Rogoża <piotr dot r dot public at gmail dot com>
+# Contributor: Piotr Rogoża <piotr dot r dot public at gmail dot com>
+
+pkgname=perl-parse-functions
+pkgver=0.01
+pkgrel=1
+_author="S/SZ/SZABGAB"
+_perlmod="Parse-Functions"
+pkgdesc="Parse-Functions - list all the functions in source code"
+arch=('any')
+url="http://search.cpan.org/dist/Parse-Functions/"
+license=('GPL' 'PerlArtistic')
+depends=(perl )
+checkdepends=(perl)
+makedepends=(perl)
+provides=(
+perl-parse-functions-csharp
+perl-parse-functions-java
+perl-parse-functions-perl
+perl-parse-functions-python
+perl-parse-functions-ruby
+)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('ba1946d453b3273530c68dcfb41eb6b0a0d8053fe0496b4dc0e6b8a9b2f69900')
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}