summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:41:24 -0600
committerJohn D Jones III2015-06-16 15:41:24 -0600
commit74356c66a24794e6632479ccfd870878b34700b5 (patch)
treeea72a53c2e0670a1dc0dc3f61f9d6dc5502498c5
downloadaur-perl-parse-plainconfig.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4746c7b3edd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-parse-plainconfig
+ pkgdesc = Parser/Generator of human-readable conf files
+ pkgver = 2.06
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Parse-PlainConfig
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-paranoid
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CO/CORLISS/Parse-PlainConfig/Parse-PlainConfig-2.06.tar.gz
+ md5sums = 0c6ba58e095dbc3183162d805abf9973
+ sha512sums = 0592b3bc79d1bdbd65b22d62443362f07131e54a5223e3043c63c68482c46051f6330b8d32ad38a917d1ccd21a5002651b8d50f425bc27297d6db7e1a5d2df57
+
+pkgname = perl-parse-plainconfig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f69e843b466
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-parse-plainconfig'
+pkgver='2.06'
+pkgrel='1'
+pkgdesc="Parser/Generator of human-readable conf files"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-paranoid')
+makedepends=()
+url='http://search.cpan.org/dist/Parse-PlainConfig'
+source=('http://search.cpan.org/CPAN/authors/id/C/CO/CORLISS/Parse-PlainConfig/Parse-PlainConfig-2.06.tar.gz')
+md5sums=('0c6ba58e095dbc3183162d805abf9973')
+sha512sums=('0592b3bc79d1bdbd65b22d62443362f07131e54a5223e3043c63c68482c46051f6330b8d32ad38a917d1ccd21a5002651b8d50f425bc27297d6db7e1a5d2df57')
+_distdir="Parse-PlainConfig-2.06"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: