summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2017-10-06 12:47:17 +0200
committerint2017-10-06 12:47:17 +0200
commit5f9db4a678586115e559025e19c6b2b8bcf0d111 (patch)
tree30f6d14b428616fb415ccb53171686a4da4c82a0
downloadaur-5f9db4a678586115e559025e19c6b2b8bcf0d111.tar.gz
Perl/CPAN Module PDF::Reuse::Barcode.
This is one of the perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -r -a" after downloading and unpacking the koha-tarball for a list of all required packages. This is with the cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b88a4b9e619e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-pdf-reuse-barcode
+ pkgdesc = Perl/CPAN Module PDF::Reuse::Barcode: Create barcodes for PDF documents with PDF::Reuse
+ pkgver = 0.07
+ pkgrel = 1
+ url = https://metacpan.org/release/PDF-Reuse-Barcode
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-barcode-code128
+ depends = perl-gd-barcode
+ depends = perl-pdf-reuse
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CN/CNIGHS/PDF-Reuse-Barcode-0.07.tar.gz
+ md5sums = 05bbc7a9d6eb8f1c187548ed5d4bb88a
+ sha512sums = e7bba6cad252dbd3ed550515d1fc3f56999df0071cd98ea97ae7a97ab3ea42b2fb749b589cd663461dbc7af145e249f2af8ea0f83b7caf0203c1c022d95c88ba
+
+pkgname = perl-pdf-reuse-barcode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1115f258bbfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer : int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-pdf-reuse-barcode'
+pkgver='0.07'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module PDF::Reuse::Barcode: Create barcodes for PDF documents with PDF::Reuse"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-barcode-code128' 'perl-gd-barcode' 'perl-pdf-reuse')
+makedepends=()
+url='https://metacpan.org/release/PDF-Reuse-Barcode'
+source=('http://search.cpan.org/CPAN/authors/id/C/CN/CNIGHS/PDF-Reuse-Barcode-0.07.tar.gz')
+md5sums=('05bbc7a9d6eb8f1c187548ed5d4bb88a')
+sha512sums=('e7bba6cad252dbd3ed550515d1fc3f56999df0071cd98ea97ae7a97ab3ea42b2fb749b589cd663461dbc7af145e249f2af8ea0f83b7caf0203c1c022d95c88ba')
+_distdir="PDF-Reuse-Barcode-0.07"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: