summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commitfc75b5f0111403f560fd81ca25db739a1efc0b1b (patch)
tree2249a1f6fc5b50c3016bd5c69435ed24d092cf75
downloadaur-fc75b5f0111403f560fd81ca25db739a1efc0b1b.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore6
-rw-r--r--ChangeLog29
-rw-r--r--PKGBUILD61
-rw-r--r--PKGBUILD.tt61
-rw-r--r--pdl-tests.patch62
-rw-r--r--perldl.conf8
7 files changed, 262 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97a9c52fd0a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = perl-pdl
+ pkgdesc = The Perl Data Language, a perl extension designed for scientific and bulk numeric data processing and display
+ pkgver = 2.006
+ pkgrel = 2
+ url = http://search.cpan.org/dist/PDL
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ makedepends = fftw2
+ makedepends = hdf4
+ makedepends = perl-opengl>=0.63
+ makedepends = plplot
+ makedepends = perl-extutils-f77
+ makedepends = proj
+ depends = perl>=5.8.9
+ depends = perl-inline>=0.43
+ depends = gsl
+ optdepends = fftw2: for PDL::FFTW support
+ optdepends = hdf4: for HDF files support
+ optdepends = perl-astro-fits-header: improved FITS files support
+ optdepends = perl-opengl>=0.63: for PDL::Graphics::TriD support
+ optdepends = plplot: for PDL::Graphics::PLplot support
+ optdepends = proj: for PDL::GIS::Proj and PDL::Transform::Proj4 support
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CH/CHM/PDL-2.006.tar.gz
+ source = perldl.conf
+ source = pdl-tests.patch
+ md5sums = df54b730453325be36b2e98ffe1f004d
+ md5sums = 9caa2b89a7f7aabfd7dcfb2c1ef79bc9
+ md5sums = a376497f3426ca19ea81a01c2c4f95c2
+
+pkgname = perl-pdl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..0fc252a9ecb8
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,29 @@
+2013-08-06 Anton Leontiev <bunder /at/ t-25.ru>
+
+ * 2.006-2 :
+ Turn on proj support.
+
+2013-08-04 Anton Leontiev <bunder /at/ t-25.ru>
+
+ * 2.006-1 :
+ New upstream release.
+
+ * perldl.conf :
+ OPTIMIZE key is added to fix building bug on x86_64 with GCC 4.8
+
+ * pdl-test.patch :
+ Commit 2a14ed6276b63c0f9642cc38f5874067775535d7 fixing tests for Perl 5.17
+
+2012-07-30 Anton Leontiev <bunder /at/ t-25.ru>
+
+ * 2.4.11-1 :
+ New upstream release.
+
+ * gsl_sf_laguerre.patch :
+ Removed. It is merged upstream.
+
+2011-11-09 Anton Leontiev <bunder /at/ t-25.ru>
+
+ * 2.4.9-2 :
+ gsl_sf_laguerre.patch added to fix issue #3434843
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83d4608044ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# CPAN Name : PDL
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: carltonf <xiong[c05]@gmail.com>
+# Contributor: Colin Pitrat <colin.pitrat@gmail.com>
+
+pkgname=perl-pdl
+pkgver=2.006
+pkgrel=2
+pkgdesc='The Perl Data Language, a perl extension designed for scientific and bulk numeric data processing and display'
+arch=('i686' 'x86_64')
+url='http://search.cpan.org/dist/PDL'
+license=('PerlArtistic' 'GPL')
+depends=(
+ 'perl>=5.8.9' # To provide ExtUtils::MakeMaker 3.61
+ 'perl-inline>=0.43'
+ 'gsl'
+)
+makedepends=(
+ 'fftw2'
+ 'hdf4'
+ 'perl-opengl>=0.63'
+ 'plplot'
+ 'perl-extutils-f77'
+ 'proj'
+)
+optdepends=(
+ 'fftw2: for PDL::FFTW support'
+ 'hdf4: for HDF files support'
+ 'perl-astro-fits-header: improved FITS files support'
+# 'perl-convert-uu: for the case when something wrong with Unicode support' # It is necessary on *BSD systems
+# 'perl-extutils-f77: for PDL::Slatec and PDL::Minuit support' # It is not necessary at runtime
+ 'perl-opengl>=0.63: for PDL::Graphics::TriD support'
+ 'plplot: for PDL::Graphics::PLplot support'
+ 'proj: for PDL::GIS::Proj and PDL::Transform::Proj4 support'
+)
+
+source=(http://search.cpan.org/CPAN/authors/id/C/CH/CHM/PDL-2.006.tar.gz perldl.conf pdl-tests.patch)
+changelog='ChangeLog'
+options=(!emptydirs)
+md5sums=('df54b730453325be36b2e98ffe1f004d' '9caa2b89a7f7aabfd7dcfb2c1ef79bc9' 'a376497f3426ca19ea81a01c2c4f95c2')
+
+build() {
+ cd "$srcdir/PDL-2.006"
+ patch -i $srcdir/pdl-tests.patch -p1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor PDLCONF=$srcdir/perldl.conf
+ make
+}
+
+check() {
+ cd "$srcdir/PDL-2.006"
+ make test
+}
+
+package() {
+ cd "$srcdir/PDL-2.006"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..2454e906dfc8
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,61 @@
+# CPAN Name : PDL
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: carltonf <xiong[c05]@gmail.com>
+# Contributor: Colin Pitrat <colin.pitrat@gmail.com>
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='The Perl Data Language, a perl extension designed for scientific and bulk numeric data processing and display'
+arch=('i686' 'x86_64')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=(
+ 'perl>=5.8.9' # To provide ExtUtils::MakeMaker 3.61
+ 'perl-inline>=0.43'
+ 'gsl'
+)
+makedepends=(
+ 'fftw2'
+ 'hdf4'
+ 'perl-opengl>=0.63'
+ 'plplot'
+ 'perl-extutils-f77'
+ 'proj'
+)
+optdepends=(
+ 'fftw2: for PDL::FFTW support'
+ 'hdf4: for HDF files support'
+ 'perl-astro-fits-header: improved FITS files support'
+# 'perl-convert-uu: for the case when something wrong with Unicode support' # It is necessary on *BSD systems
+# 'perl-extutils-f77: for PDL::Slatec and PDL::Minuit support' # It is not necessary at runtime
+ 'perl-opengl>=0.63: for PDL::Graphics::TriD support'
+ 'plplot: for PDL::Graphics::PLplot support'
+ 'proj: for PDL::GIS::Proj and PDL::Transform::Proj4 support'
+)
+
+source=([% source %] perldl.conf pdl-tests.patch)
+changelog='ChangeLog'
+options=(!emptydirs)
+md5sums=('[% md5sums %]' '9caa2b89a7f7aabfd7dcfb2c1ef79bc9' 'a376497f3426ca19ea81a01c2c4f95c2')
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ patch -i $srcdir/pdl-tests.patch -p1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor PDLCONF=$srcdir/perldl.conf
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/pdl-tests.patch b/pdl-tests.patch
new file mode 100644
index 000000000000..06170b9f6990
--- /dev/null
+++ b/pdl-tests.patch
@@ -0,0 +1,62 @@
+From 2a14ed6276b63c0f9642cc38f5874067775535d7 Mon Sep 17 00:00:00 2001
+From: Chris Marshall <devel.chm.01@gmail.com>
+Date: Thu, 28 Mar 2013 09:23:18 -0400
+Subject: [PATCH] Fix %hash randomization bugs in PDL tests
+
+It appears that t/hdr.t and t/niceslice.t tests
+had hash comparison checks assuming (%h1) and (%h2)
+if the two hashes were equal. This should fix
+perl 5.17.x failures for PDL-2.006
+---
+ t/hdrs.t | 6 +++++-
+ t/niceslice.t | 10 ++++++++--
+ 2 files changed, 13 insertions(+), 3 deletions(-)
+
+diff --git a/t/hdrs.t b/t/hdrs.t
+index 15da81e..893edcf 100644
+--- a/t/hdrs.t
++++ b/t/hdrs.t
+@@ -16,7 +16,11 @@ sub hdrcmp {
+ my ($ah,$bh) = map {$_->gethdr} @_;
+ # Copy-by-reference test is obsolete; check contents instead (CED 12-Apr-2003)
+ # return $ah==$bh
+- return join("",%{$ah}) eq join("",%{$bh});
++ my %ahh = %{$ah};
++ my (@ahhkeys) = sort keys %ahh;
++ my %bhh = %{$bh};
++ my (@bhhkeys) = sort keys %bhh;
++ return join("",@bhh{@bhhkeys}) eq join("",@ahh{@ahhkeys});
+ }
+
+ print "1..9\n";
+diff --git a/t/niceslice.t b/t/niceslice.t
+index 3f6de15..3c35eee 100644
+--- a/t/niceslice.t
++++ b/t/niceslice.t
+@@ -6,7 +6,7 @@ use PDL::LiteF;
+ BEGIN {
+ eval 'require PDL::NiceSlice';
+ unless ($@) {
+- plan tests => 43,
++ plan tests => 44,
+ # todo => [37..40],
+ } else {
+ plan tests => 1;
+@@ -208,7 +208,13 @@ eval translate_and_show '$b = $a(1:2,pdl(0,2));';
+ # Old hdrcpy test (for copy-by-reference); this is obsolete
+ # with quasi-deep copying. --CED 11-Apr-2003
+ # ok (!$@ and $b->gethdr() == $h);
+-ok(!$@ and join("",%{$b->gethdr}) eq join("",%{$h}));
++if ( ok(!$@) ) {
++ my %bh = %{$b->gethdr};
++ my (@bhkeys) = sort keys %bh;
++ my %hh = %{$h};
++ my (@hhkeys) = sort keys %hh;
++ ok(join("",@bh{@bhkeys}) eq join("",@hh{@hhkeys}));
++}
+
+ $a = ones(10);
+ my $i = which $a < 0;
+--
+1.7.4.1
+
diff --git a/perldl.conf b/perldl.conf
new file mode 100644
index 000000000000..a0e615ab34aa
--- /dev/null
+++ b/perldl.conf
@@ -0,0 +1,8 @@
+#!/usr/bin/perl
+# -*-perl-*-
+
+%PDL_CONFIG = (
+ # Fix building on x86_64 with GCC 4.8
+ # For more info see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=701335
+ OPTIMIZE => "$Config{optimize} -fno-aggressive-loop-optimizations"
+);