summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2024-03-27 18:31:37 +0100
committerMichal Wojdyla2024-03-27 18:31:37 +0100
commit3092ee28c82bfdb22b77b72fa0a9fd2cc6a0f2ba (patch)
tree047908f5ce5b82d78357027bd65e5edfb7336df8
parentf338e324c65a34cb2df82ec6f528d9f3762d857e (diff)
downloadaur-perl-plack-middleware-debug.tar.gz
update to 0.18
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 17 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a0f18faddb0..76774ba389be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = perl-plack-middleware-debug
pkgdesc = display information about the current request/response
- pkgver = 0.14
+ pkgver = 0.18
pkgrel = 1
url = http://search.cpan.org/dist/Plack-Middleware-Debug
arch = any
license = PerlArtistic
license = GPL
+ makedepends = perl-module-build-tiny
depends = perl>=5.8.1
depends = perl-class-method-modifiers>=1.05
depends = perl-data-dump
+ depends = perl-data-dumper-concise
depends = perl-file-sharedir>=1.00
depends = perl-plack
depends = perl-text-microtemplate>=0.15
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Plack-Middleware-Debug-0.14.tar.gz
- md5sums = 55b4d11e38299002cf68b6b0fd91631e
- sha512sums = d176656dc1aa2cfad0ecbe5b9d9ee667c8ab606ef670c1a67788109bd24d57e8bf8bb03b1c333c2460e053e2a3d04abfeabc3a82970093ef40ed7b73d0a9c17d
+ source = http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Plack-Middleware-Debug-0.18.tar.gz
+ md5sums = 986abef34388a1a422c15e377c64b501
+ sha512sums = 802a9aafbebf7a0bcd49c82ab64f240444369128d45b52c6602ce740fe664d7eaec7d27fa17daf946182de0cc4ac73421c9f467dda897c270c5c3d933d39130a
pkgname = perl-plack-middleware-debug
-
diff --git a/PKGBUILD b/PKGBUILD
index a36b7fa64e7d..dd179b57a0d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
pkgname='perl-plack-middleware-debug'
-pkgver='0.14'
+pkgver='0.18'
pkgrel='1'
pkgdesc="display information about the current request/response"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-depends=('perl>=5.8.1' 'perl-class-method-modifiers>=1.05' 'perl-data-dump' 'perl-file-sharedir>=1.00' 'perl-plack' 'perl-text-microtemplate>=0.15')
-makedepends=()
+depends=('perl>=5.8.1' 'perl-class-method-modifiers>=1.05' 'perl-data-dump' 'perl-data-dumper-concise' 'perl-file-sharedir>=1.00' 'perl-plack' 'perl-text-microtemplate>=0.15')
+makedepends=('perl-module-build-tiny')
url='http://search.cpan.org/dist/Plack-Middleware-Debug'
-source=('http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Plack-Middleware-Debug-0.14.tar.gz')
-md5sums=('55b4d11e38299002cf68b6b0fd91631e')
-sha512sums=('d176656dc1aa2cfad0ecbe5b9d9ee667c8ab606ef670c1a67788109bd24d57e8bf8bb03b1c333c2460e053e2a3d04abfeabc3a82970093ef40ed7b73d0a9c17d')
-_distdir="Plack-Middleware-Debug-0.14"
+source=('http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Plack-Middleware-Debug-0.18.tar.gz')
+md5sums=('986abef34388a1a422c15e377c64b501')
+sha512sums=('802a9aafbebf7a0bcd49c82ab64f240444369128d45b52c6602ce740fe664d7eaec7d27fa17daf946182de0cc4ac73421c9f467dda897c270c5c3d933d39130a')
+_distdir="Plack-Middleware-Debug-0.18"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -24,27 +23,20 @@ build() {
MODULEBUILDRC=/dev/null
cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
+ /usr/bin/perl Build.PL
+ /usr/bin/perl Build
)
}
check() {
cd "$srcdir/$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
+ /usr/bin/perl Build test
)
}
package() {
cd "$srcdir/$_distdir"
- make install
-
+ /usr/bin/perl Build install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: