summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2020-05-22 11:19:13 +0200
committerJakob Gahde2020-05-22 11:19:13 +0200
commit1f662fc77b71d770603b74f65ef776e850e14c7b (patch)
tree76e0b6a7ffba3aa5acc853159ff3d97cab93a23d
parent5e1fa162309f6127ff6142976c0f80535ca0433d (diff)
downloadaur-1f662fc77b71d770603b74f65ef776e850e14c7b.tar.gz
perl-pod-constants 0.19-1: Update to new version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6b00137a651..c419ceb39755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = perl-pod-constants
pkgdesc = Include constants from POD
- pkgver = 0.17
+ pkgver = 0.19
pkgrel = 1
- url = http://search.cpan.org/dist/Pod-Constants
- arch = i686
- arch = x86_64
- license = PerlArtistic
- license = GPL
+ url = https://git.ieval.ro/?p=pod-constants.git
+ arch = any
+ license = Artistic2.0
depends = perl
- options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/S/SA/SAMV/Pod-Constants-0.17.tar.gz
- md5sums = 9b3b9a377ef2f7e70d404155fa38059e
+ source = https://www.cpan.org/modules/by-module/Pod/Pod-Constants-0.19.tar.gz
+ sha512sums = 4c7b7ccdede87f0069bf100406de5b2320b5f9cb0363d413e90b419e512d4322114851d78fdd7a1bce63347ee5986ecd397b11579b91eee6e46d9b0a82b0b64a
pkgname = perl-pod-constants
diff --git a/PKGBUILD b/PKGBUILD
index 98673e24ead9..2dd5a7c7237c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
# Contributor: gilles DOT quenot AT gmail DOT com
-# Generator : CPANPLUS::Dist::Arch 0.18
-pkgname='perl-pod-constants'
-pkgver='0.17'
-pkgrel='1'
+
+pkgname=perl-pod-constants
+pkgver=0.19
+pkgrel=1
pkgdesc="Include constants from POD"
-arch=('i686' 'x86_64')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
+arch=('any')
+license=('Artistic2.0')
depends=('perl')
-url='http://search.cpan.org/dist/Pod-Constants'
-source=("http://search.cpan.org/CPAN/authors/id/S/SA/SAMV/Pod-Constants-${pkgver}.tar.gz")
-md5sums=('9b3b9a377ef2f7e70d404155fa38059e')
-_dist_dir="Pod-Constants-${pkgver}"
+url="https://git.ieval.ro/?p=pod-constants.git"
+source=("https://www.cpan.org/modules/by-module/Pod/Pod-Constants-${pkgver}.tar.gz")
+sha512sums=('4c7b7ccdede87f0069bf100406de5b2320b5f9cb0363d413e90b419e512d4322114851d78fdd7a1bce63347ee5986ecd397b11579b91eee6e46d9b0a82b0b64a')
+
build() {
- export PERL_MM_USE_DEFAULT=1
- { cd "$_dist_dir" &&
- perl Makefile.PL INSTALLDIRS=vendor &&
- make &&
- make test
- } || return 1;
+ cd "${srcdir}/Pod-Constants-${pkgver}"
+
+ perl Makefile.PL NO_PACKLIST=true
+ make
+}
+
+check() {
+ cd "${srcdir}/Pod-Constants-${pkgver}"
+ make test
}
package() {
- cd "$_dist_dir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
- make DESTDIR="$pkgdir" install;
+ cd "${srcdir}/Pod-Constants-${pkgver}"
+
+ make pure_install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
}