summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Bunkus2017-05-15 12:40:24 +0200
committerMoritz Bunkus2017-05-15 12:40:24 +0200
commita4812e82b3e84d1a9a85ef6683db9e3b975b7093 (patch)
tree743c4034dc19e2e2f0243fd7f7f151578119f5e7
downloadaur-a4812e82b3e84d1a9a85ef6683db9e3b975b7093.tar.gz
initial packaging
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92bc8ea158ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon May 15 10:40:13 UTC 2017
+pkgbase = perl-pod-latex
+ pkgdesc = Convert Pod data to formatted LaTeX
+ pkgver = 0.61
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Pod-LaTeX/
+ arch = any
+ license = PerlArtistic
+ makedepends = perl-module-build
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/T/TJ/TJENNESS/Pod-LaTeX-0.61.tar.gz
+ sha512sums = c9b5d8b50f630e25e1f913d95d83a1323e71d2c5a3a794a543bdc9962800e5979b3e58595e7a653a96f9aea1f321c1564e2062e9b9d70d8c4d1c6729cb8df498
+
+pkgname = perl-pod-latex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa9122c5d082
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Moritz Bunkus <moritz@bunkus.org>
+
+pkgname=perl-pod-latex
+pkgver='0.61'
+pkgrel='1'
+pkgdesc="Convert Pod data to formatted LaTeX"
+arch=(any)
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/Pod-LaTeX/"
+options=('!emptydirs')
+makedepends=('perl-module-build')
+source=("http://search.cpan.org/CPAN/authors/id/T/TJ/TJENNESS/Pod-LaTeX-${pkgver}.tar.gz")
+sha512sums=('c9b5d8b50f630e25e1f913d95d83a1323e71d2c5a3a794a543bdc9962800e5979b3e58595e7a653a96f9aea1f321c1564e2062e9b9d70d8c4d1c6729cb8df498')
+
+prepare_environment() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ cd "${srcdir}/Pod-LaTeX-${pkgver}"
+}
+
+build() {
+ prepare_environment
+ /usr/bin/perl Build.PL
+ ./Build
+}
+
+check() {
+ prepare_environment
+ ./Build test
+}
+
+package() {
+ prepare_environment
+ ./Build install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: