summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:45:47 -0600
committerJohn D Jones III2015-06-16 15:45:47 -0600
commita5f68194901f643b51b0e7f17d2aa9187d2dfa7e (patch)
tree271da596ab4e87cec7559ef5a76dab0439a0a5ff
downloadaur-a5f68194901f643b51b0e7f17d2aa9187d2dfa7e.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4430912fff4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-pod-spelling
+ pkgdesc = Send POD to a spelling checker
+ pkgver = 0.17
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Pod-Spelling
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ makedepends = perl-test-pod
+ depends = perl-pod-pom>=0.04
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/L/LG/LGODDARD/Pod-Spelling-0.17.tar.gz
+ md5sums = 9240a8c7b6d9531f508fa27ec08c3c70
+ sha512sums = e4b7418d73b5b0addc821475942437e1257fc87318d23d88a2b83a306ab6f71df0af1758ce77a82782424aac9d24518b5392c06421affa659634555658926550
+
+pkgname = perl-pod-spelling
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb4fa4eec3f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-pod-spelling'
+pkgver='0.17'
+pkgrel='1'
+pkgdesc="Send POD to a spelling checker"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-pod-pom>=0.04')
+makedepends=('perl-test-pod')
+url='http://search.cpan.org/dist/Pod-Spelling'
+source=('http://search.cpan.org/CPAN/authors/id/L/LG/LGODDARD/Pod-Spelling-0.17.tar.gz')
+md5sums=('9240a8c7b6d9531f508fa27ec08c3c70')
+sha512sums=('e4b7418d73b5b0addc821475942437e1257fc87318d23d88a2b83a306ab6f71df0af1758ce77a82782424aac9d24518b5392c06421affa659634555658926550')
+_distdir="Pod-Spelling-0.17"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: