summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Phillips2016-03-28 12:38:40 +1300
committerDavid Phillips2016-03-28 12:38:40 +1300
commit33dab27fb1cea3a7cb56d0d4492870edb1b030bd (patch)
treead0df47cec25a7ee82e7976506595d4a25599661
downloadaur-33dab27fb1cea3a7cb56d0d4492870edb1b030bd.tar.gz
Initial
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b1f4ab71672
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Mar 27 23:38:29 UTC 2016
+pkgbase = perl-poe-component-irc
+ pkgdesc = A fully event-driven IRC client module
+ pkgver = 6.88
+ pkgrel = 2
+ url = http://search.cpan.org/dist/POE-Component-IRC
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ depends = glibc
+ depends = perl-poe
+ depends = perl-poe-filter-ircd
+ depends = perl-poe-component-pluggable
+ depends = perl-poe-component-client-dns
+ depends = perl-irc-utils
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BI/BINGOS/POE-Component-IRC-6.88.tar.gz
+ sha256sums = 5d7f2168383c93e54b00d06695cc52f514a921e1ee4f45a05950700f50075a8f
+
+pkgname = perl-poe-component-irc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e706f8e49132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer : David Phillips < dbphillipsnz , gmail >
+# Contributor: Jakob Nixdorf <flocke [swirly thing] shadowice [dot] org>
+
+pkgname=perl-poe-component-irc
+pkgver=6.88
+pkgrel=2
+pkgdesc="A fully event-driven IRC client module"
+depends=('perl>=5.10.0' 'glibc' 'perl-poe' 'perl-poe-filter-ircd' 'perl-poe-component-pluggable' 'perl-poe-component-client-dns' 'perl-irc-utils')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/POE-Component-IRC"
+source=(http://search.cpan.org/CPAN/authors/id/B/BI/BINGOS/POE-Component-IRC-${pkgver}.tar.gz)
+sha256sums=('5d7f2168383c93e54b00d06695cc52f514a921e1ee4f45a05950700f50075a8f')
+options=('!emptydirs')
+arch=('i686' 'x86_64')
+
+build()
+{
+ cd "${srcdir}/POE-Component-IRC-${pkgver}"
+
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package()
+{
+ cd "${srcdir}/POE-Component-IRC-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Remove .packlist and perllocal.pod files.
+ find "${pkgdir}" -name '.packlist' -delete
+ find "${pkgdir}" -name 'perllocal.pod' -delete
+}