summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:47:55 -0600
committerJohn D Jones III2015-06-16 15:47:55 -0600
commit85579efd0677f189f82c5efe0b7e558d9843a695 (patch)
treecfc41d13b54a9d544b6a230e5d300c58be5cd266
downloadaur-85579efd0677f189f82c5efe0b7e558d9843a695.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df3eea17cc10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-prefork
+ pkgdesc = Optimized module loading for forking or non-forking processes
+ pkgver = 1.04
+ pkgrel = 1
+ url = http://search.cpan.org/dist/prefork
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/prefork-1.04.tar.gz
+ md5sums = 47a514d4058ffc8cca184b28d6d54d0a
+ sha512sums = 80fd65f9255116cc54421000557369e4d852444d921a1ef4dadf12a7ad4bd06e641787e57df57fc0180be092d3ca546e42e9ec03cf59d0170db1197140613f54
+
+pkgname = perl-prefork
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc74fb6cc573
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-prefork'
+pkgver='1.04'
+pkgrel='1'
+pkgdesc="Optimized module loading for forking or non-forking processes"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/prefork'
+source=('http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/prefork-1.04.tar.gz')
+md5sums=('47a514d4058ffc8cca184b28d6d54d0a')
+sha512sums=('80fd65f9255116cc54421000557369e4d852444d921a1ef4dadf12a7ad4bd06e641787e57df57fc0180be092d3ca546e42e9ec03cf59d0170db1197140613f54')
+_distdir="prefork-1.04"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: