summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:48:45 -0600
committerJohn D Jones III2015-06-16 15:48:45 -0600
commit7878393baf56e48da544c2eb28c11f9c4a9e0c2a (patch)
treea87323a17578856e9ec1e8a41e7c40db34516e58
downloadaur-7878393baf56e48da544c2eb28c11f9c4a9e0c2a.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..775e42674f83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-protocol-websocket
+ pkgdesc = WebSocket protocol
+ pkgver = 0.16
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Protocol-WebSocket
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-digest-sha1>=0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/V/VT/VTI/Protocol-WebSocket-0.16.tar.gz
+ md5sums = bebdc21b9a895bc46901d6269b28410e
+ sha512sums = b3e01a7f4ec4bf8ed40c7b8d10a20c5b9c141145b273d0e89ac602acb015cb345d274c00f0d48c6eebd4f5312db6cdf8c94d55448bf21b83342b40c9212c1afc
+
+pkgname = perl-protocol-websocket
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b0f891b20d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.27
+
+pkgname='perl-protocol-websocket'
+pkgver='0.16'
+pkgrel='1'
+pkgdesc="WebSocket protocol"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-digest-sha1>=0')
+makedepends=()
+url='http://search.cpan.org/dist/Protocol-WebSocket'
+source=('http://search.cpan.org/CPAN/authors/id/V/VT/VTI/Protocol-WebSocket-0.16.tar.gz')
+md5sums=('bebdc21b9a895bc46901d6269b28410e')
+sha512sums=('b3e01a7f4ec4bf8ed40c7b8d10a20c5b9c141145b273d0e89ac602acb015cb345d274c00f0d48c6eebd4f5312db6cdf8c94d55448bf21b83342b40c9212c1afc')
+_distdir="Protocol-WebSocket-0.16"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Build.PL
+ /usr/bin/perl Build
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ /usr/bin/perl Build test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Build install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: