summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Cafe2017-01-21 19:29:52 -0200
committerDaniel Cafe2017-01-21 19:29:52 -0200
commitda2d15496b5129810d95596fe9c07e0013e762d8 (patch)
tree195927b833538250604b13633c8a8ee7c29688a1
downloadaur-da2d15496b5129810d95596fe9c07e0013e762d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c58bb16d86fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-quota
+ pkgdesc = Quota - Perl interface to file system quotas
+ pkgver = 1.7.2
+ pkgrel = 1
+ url = https://metacpan.org/release/Quota
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/T/TO/TOMZO/Quota-1.7.2.tar.gz
+ md5sums = d4ed0acc56ece4e5080a7a6d827e9c66
+
+pkgname = perl-quota
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d3a53dfabf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Daniel Café <dccafe@gmail.com>
+pkgname=perl-quota
+pkgver=1.7.2
+pkgrel=1
+pkgdesc='Quota - Perl interface to file system quotas'
+_dist=Quota
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/T/TO/TOMZO/$_dist-$pkgver.tar.gz")
+md5sums=(d4ed0acc56ece4e5080a7a6d827e9c66)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}