summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryar2016-12-15 18:00:31 -0800
committeryar2016-12-15 18:00:31 -0800
commitd92f64091725a1eb1e8b5dce7aa733f6f4ebe8d4 (patch)
treeff9cc589f8b0ec9054de51e2afeaf5f43a55a34d
downloadaur-d92f64091725a1eb1e8b5dce7aa733f6f4ebe8d4.tar.gz
init: perl-return-type 0.005
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acdfcb282431
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Dec 16 02:00:30 UTC 2016
+pkgbase = perl-return-type
+ pkgdesc = Perl Return::Type CPAN module
+ pkgver = 0.005
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Return-Type/
+ arch = any
+ license = unknown
+ depends = perl
+ depends = perl-test-fatal
+ depends = perl-type-tiny
+ options = !emptydirs
+ source = http://www.cpan.org/authors/id/T/TO/TOBYINK/Return-Type-0.005.tar.gz
+ sha256sums = 6666f8103cfa6beb2bc71a20f2686bd98bbd5edf1e9df9d60e0a6dc2b7f3293a
+
+pkgname = perl-return-type
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..afb18ffd7813
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+Return-Type-*.tar.gz
+perl-return-type-*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16aa76c857d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yardena Cohen <yardenack at gmail dot com>
+
+cpaname=Return-Type
+cpanauthor=TOBYINK
+pkgname=perl-return-type
+pkgver=0.005
+pkgrel=1
+pkgdesc="Perl Return::Type CPAN module"
+arch=('any')
+url="http://search.cpan.org/dist/${cpaname}/"
+license=('unknown')
+options=('!emptydirs')
+depends=('perl' 'perl-test-fatal' 'perl-type-tiny')
+source=("http://www.cpan.org/authors/id/${cpanauthor::1}/${cpanauthor::2}/${cpanauthor}/${cpaname}-${pkgver}.tar.gz")
+sha256sums=('6666f8103cfa6beb2bc71a20f2686bd98bbd5edf1e9df9d60e0a6dc2b7f3293a')
+
+build() {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ make test
+}
+
+package () {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+}