summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:52:03 -0600
committerJohn D Jones III2015-06-16 15:52:03 -0600
commitcd7dd320a3dbd11002ed859bcb092a4b1b8fafdf (patch)
tree29c963df5a3ae774240e4793501859bc8c7918f9
downloadaur-perl-sepia.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4092bb869927
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-sepia
+ pkgdesc = Simple Emacs-Perl InterAction
+ pkgver = 0.992
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Sepia
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SE/SEANO/Sepia-0.992.tar.gz
+ md5sums = 6998853d0b083981a1545b29a757272d
+ sha512sums = b1c73aa8d0788eaafd5020c06caebe3a78361d81abbb2e29b7c32aef08ee16288cf85a1b6457e2243ac2cabaa9da5baa56508d70cd12d5e2bf6b2109407ff079
+
+pkgname = perl-sepia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50778e7aec70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-sepia'
+pkgver='0.992'
+pkgrel='1'
+pkgdesc="Simple Emacs-Perl InterAction"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Sepia'
+source=('http://search.cpan.org/CPAN/authors/id/S/SE/SEANO/Sepia-0.992.tar.gz')
+md5sums=('6998853d0b083981a1545b29a757272d')
+sha512sums=('b1c73aa8d0788eaafd5020c06caebe3a78361d81abbb2e29b7c32aef08ee16288cf85a1b6457e2243ac2cabaa9da5baa56508d70cd12d5e2bf6b2109407ff079')
+_distdir="Sepia-0.992"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: