summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit5c59a0962d113484671691d5e8f8b53e08c8c14e (patch)
treebc4a4c849c849aa24079d3416b1382ec41384bc8
downloadaur-5c59a0962d113484671691d5e8f8b53e08c8c14e.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--PKGBUILD.tt32
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fb6fe2fc5c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-shell-command
+ pkgdesc = Perl module providing cross-platform functions emulating common shell commands
+ pkgver = 0.06
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Shell-Command
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Shell-Command-0.06.tar.gz
+ md5sums = d3e42d3cb2ea325dc1059bb8706b47bb
+
+pkgname = perl-shell-command
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a27ed9917006
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# CPAN Name : Shell::Command
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.13
+
+pkgname=perl-shell-command
+pkgver=0.06
+pkgrel=1
+pkgdesc="Perl module providing cross-platform functions emulating common shell commands"
+arch=("any")
+url="http://search.cpan.org/dist/Shell-Command"
+license=("PerlArtistic" "GPL")
+depends=("perl")
+source=(http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Shell-Command-0.06.tar.gz)
+options=(!emptydirs)
+md5sums=("d3e42d3cb2ea325dc1059bb8706b47bb")
+
+build() {
+ cd "$srcdir/Shell-Command-0.06"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/Shell-Command-0.06"
+ make test
+}
+
+package() {
+ cd "$srcdir/Shell-Command-0.06"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..184a09d3ee4e
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : Shell::Command
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc="Perl module providing cross-platform functions emulating common shell commands"
+arch=("any")
+url="[% url %]"
+license=("PerlArtistic" "GPL")
+depends=("perl")
+source=([% source %])
+options=(!emptydirs)
+md5sums=("[% md5sums %]")
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}