summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrás Wacha2022-04-20 11:39:33 +0200
committerAndrás Wacha2022-04-20 11:39:33 +0200
commitc56f51d052e21cd9faac62a9181ae9655a2cb550 (patch)
tree8026829ca91e3e4d040a0133dbf1593d0aca21f5
parenta51aa80baf1d2ed973105961196f1d05ef9602dc (diff)
downloadaur-c56f51d052e21cd9faac62a9181ae9655a2cb550.tar.gz
Workaround for unsupported code in lib/Starlink/AST.xs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01d1246e8f80..3d96d533a6c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-starlink-ast
pkgdesc = Interface to the Starlink AST library
pkgver = 3.01
- pkgrel = 4
+ pkgrel = 5
url = https://metacpan.org/release/Starlink-AST
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1b2d42df6bf6..182bf622bda0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='perl-starlink-ast'
pkgver='3.01'
-pkgrel='4'
+pkgrel='5'
pkgdesc="Interface to the Starlink AST library"
arch=('i686' 'x86_64')
license=('PerlArtistic' 'GPL')
@@ -17,8 +17,6 @@ md5sums=('db53bc018bd349e3a0c85bd8c6883f3c')
sha512sums=('0beddc6c7c76f260725aa0958b2c82c2496b80c94529fca37e912493d45b09a07494f2b1bb3b0eb0ca99f61c6f415a6671240e9e69a8bef166d6b1591a00ddcf')
_distdir="Starlink-AST-${pkgver}"
-# Pacman v6.0.0 sets -Werror=format-security in /etc/makepkg.conf. This breaks the compilation of lib/Starlink/AST.xs
-CFLAGS="${CFLAGS} -Wno-error=format-security"
build() {
@@ -30,7 +28,8 @@ build() {
cd "$srcdir/$_distdir"
/usr/bin/perl Build.PL
- /usr/bin/perl Build
+ # lib/Starlink/AST.xs in version 3.01 has some unlucky parts where the default "-Werror=format-security" in Perl's Config.pm errors out.
+ /usr/bin/perl Build --config optimize="${CFLAGS} -W'no-error=format-security'"
)
}