summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2014-06-09 08:27:58 +0400
committerAnton Leontiev2015-02-15 07:48:22 +0300
commitee46c789bfd9ec4b1f9ee3077d8a9341be363012 (patch)
treeb4b7acc665dc8a1d06d4f2ea5d5c123e56aac188
downloadaur-ee46c789bfd9ec4b1f9ee3077d8a9341be363012.tar.gz
Initial v0.15
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--PKGBUILD.tt32
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1307e904d2be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-string-print
+ pkgdesc = Perl package providing printf() alternative
+ pkgver = 0.15
+ pkgrel = 1
+ url = http://search.cpan.org/dist/String-Print
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl>=5.10.1
+ depends = perl-unicode-linebreak
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/String-Print-0.15.tar.gz
+ md5sums = 469f5a0517a6820abe52f7e23dc9e58b
+
+pkgname = perl-string-print
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7074bb0a9404
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# CPAN Name : String::Print
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname=perl-string-print
+pkgver=0.15
+pkgrel=1
+pkgdesc='Perl package providing printf() alternative'
+arch=('any')
+url='http://search.cpan.org/dist/String-Print'
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.10.1' 'perl-unicode-linebreak')
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/String-Print-0.15.tar.gz)
+options=(!emptydirs)
+md5sums=('469f5a0517a6820abe52f7e23dc9e58b')
+
+build() {
+ cd String-Print-0.15
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd String-Print-0.15
+ make test
+}
+
+package() {
+ cd String-Print-0.15
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..ec5a5467b145
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : String::Print
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl package providing printf() alternative'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.10.1' 'perl-unicode-linebreak')
+source=([% source %])
+options=(!emptydirs)
+md5sums=('[% md5sums %]')
+
+build() {
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd [% distdir %]
+ make test
+}
+
+package() {
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}