summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commitc0e92df8a7e790bae2a8a3c4aabcf5feb011ce33 (patch)
tree0e6f859b7bcfd85d41ec13cefb3bb1a6d4621011
downloadaur-c0e92df8a7e790bae2a8a3c4aabcf5feb011ce33.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..413f9d9b0ff4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-sys-filesystem
+ pkgdesc = Retrieve list of filesystems and their properties
+ pkgver = 1.406
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Sys-Filesystem/
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-module-pluggable
+ depends = perl-params-util
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/R/RE/REHSACK/Sys-Filesystem-1.406.tar.gz
+ sha256sums = 9a1d43326226f8aea3359849383784840ef930e5c4efafa4cbd5764d2c7a6afb
+
+pkgname = perl-sys-filesystem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f70598ff7a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Mantainer: 3ED <krzysztof1987 at gmail dot com>
+#
+pkgname=perl-sys-filesystem
+_lastauthor=R/RE/REHSACK
+_pkgname=Sys-Filesystem
+pkgver=1.406
+pkgrel=1
+pkgdesc='Retrieve list of filesystems and their properties'
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-module-pluggable' 'perl-params-util')
+url="http://search.cpan.org/dist/${_pkgname}/"
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('9a1d43326226f8aea3359849383784840ef930e5c4efafa4cbd5764d2c7a6afb')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make install
+}
+