summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:57:12 -0600
committerJohn D Jones III2015-06-16 15:57:12 -0600
commit952a4c2233e17f818ea22b925ff6c84b7a1ffd27 (patch)
tree599131b4ccbcf6b36f6579f561e6fa37cc852a69
downloadaur-952a4c2233e17f818ea22b925ff6c84b7a1ffd27.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac9eac50e394
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-taint
+ pkgdesc = Perl utility extensions for tainted data
+ pkgver = 0.09
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Taint
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PH/PHOENIX/Taint-0.09.tar.gz
+ md5sums = e9b23bec1f15ee2f1e1d7309eb04ef92
+ sha512sums = 50547d198f9c77a92c1d55cd903b1a3325873ac1b309edfed568f17d3b9045d90dcfeb81493a0cda06882a55c8f03ce77317358d11d25a9caaee446dd31bc40d
+
+pkgname = perl-taint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96fdaf72dfb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-taint'
+pkgver='0.09'
+pkgrel='1'
+pkgdesc="Perl utility extensions for tainted data"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Taint'
+source=('http://search.cpan.org/CPAN/authors/id/P/PH/PHOENIX/Taint-0.09.tar.gz')
+md5sums=('e9b23bec1f15ee2f1e1d7309eb04ef92')
+sha512sums=('50547d198f9c77a92c1d55cd903b1a3325873ac1b309edfed568f17d3b9045d90dcfeb81493a0cda06882a55c8f03ce77317358d11d25a9caaee446dd31bc40d')
+_distdir="Taint-0.09"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: